Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This may sound as a stupid question, but I am really interested whether Ubuntu Desktop i386 will be able to use all my available RAM. I want to use the latest, non-LTS version, 10.10. It says on the website that it's (i386) the Recommended version. I also recall that Flash Player had issues with 64 bit Linux. Also, the 64 bit version is listed in the Universal USB Installer as amd64. Does this mean that it's using instruction sets specific to AMD CPUs? (I have an Intel) Will it work fine with Intel?

So which one to download and install? What to do to be able to use 8Gb of RAM?

share|improve this question
    
add comment

3 Answers

up vote 1 down vote accepted

Also, the 64 bit version is listed in the Universal USB Installer as amd64. Does this mean that it's using instruction sets specific to AMD CPUs?

No, it's not restricted to AMD users. amd64 is called so for historic reasons. I'd recommend the 64-bit version ( aka amd64 version). You'll have to install the 32-bit version of flash player

share|improve this answer
1  
There is an experimental amd64 flash player too. No need for cross-libraries at the moment. Though, Ubuntu will install the 32bit/cross-lib ones. –  Shiki Dec 21 '10 at 19:39
add comment

PAE allows you to use more than 4GB RAM on most 32-bit systems (the notable exceptions are the non-server versions of Windows). For 32-bit Linux, the limit is 64 GB.

Ubuntu 10.04 or above automatically installs the PAE enabled kernel if it detects more than 3 GB of available memory. The 32-bit desktop version should work for you.

If it couldn't detect your 8GB RAM, manually install the PAE kernel with

sudo aptitude install linux-generic-pae linux-headers-generic-pae

As far as I know, the 32-bit version use less memory, has better hardware compatibility, but has lower performance on computationally intensive programs. Please correct me if I'm wrong.

See also:

share|improve this answer
1  
Note though that single apps will still be limited to 4GB of memory. I haven't had any hardware problems with 64bit with my systems and e.g startup is clearly faster. I don't think there is significant difference in memory usage. –  Matti Pastell Dec 21 '10 at 19:57
    
Thanks for the help. Although this answer was very helpful, I followed the other way. I will try to do what you wrote. I didn't know whether Ubuntu has PAE (it said it had, but I only saw 3.2GiB on my 4Gb old PC). –  AlexanderMP Dec 21 '10 at 22:18
add comment

You'll need the 64bit version with your RAM. I haven't had any issues with flash or Java in 10.10 or 10.04, which I had with older versions a couple of years ago. And yes amd64 works well with Intels too, they should really change the name...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.