Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Need some major help. Running a Dell XPS/Dimension 630i. It came with "SATA 2 RAID 0 With Dual 500GB Hard Drives." I have installed a new, third non-raided drive and installed Ubuntu on it.

So now I have Windows on the original hard drive and Ubuntu Linux on the new HD. When I get to the boot menu where I can select an OS, if I select windows I get an error: "No such drive, no such disk." Also, strangely in the first place, in order to even get to the bootloader menu I have had to disable ALL ports under the RAID config. Unless I do this, I will just get to a never-ending blinking cursor.

I have tried every conceivable CMOS config and nothing else works. Tried setting port 3 (the new HD w/ Ubuntu) to first hard disk boot priority. Tried disabling all other ports and enabling the Ubuntu HD port and vice versa.

Here's a pic of the error I get when I try to boot to Windows:

enter image description here

Also, please note that I can actually access all files from the raided Windows drive through Ubuntu.

(Someone suggested just reinstalling windows from installation CD. Agree?)

share|improve this question
    
Did you try removing the HDDs from the SATA cables and swapping them. This will troubleshoot both bad cables (unlikely) and bad motherboard sockets for the SATA cables. Let me know if this helps. –  David Dec 21 '10 at 19:22
    
@david: thanks! so just take the two original drives and switch them from 0 and 1 to 2 and 3 and put the Ubuntu drive in port 0? –  LuxuryMode Dec 21 '10 at 19:25
    
also, under raid config, would I disable the ubuntu port, since its unraided (or using fakeraid)? –  LuxuryMode Dec 21 '10 at 19:26
    
Well crap, I didn't see that it was raided. This could break the Raid array. Hmm... If you could do some editing of the RAID that you feel comfortable with go for it. I wouldn't feel comfortable with tampering with a RAID array like that. Sorry. Try swapping out the SATA cables though, at least you could check something like that. I don't know what else to do when dealing with a RAID. –  David Dec 21 '10 at 19:35
    
When you say swap, you mean just switch the cables to different hard drives? wont things get funny if i use one of the cables currently connected to the dual raided drives for the ubuntu drive? Also, someone else suggested that they believe the issue to be in the boot sector of my raid 0. He said he believed I did not flag my new 3rd drive as bootable and GRUB installed the bootloader onto my RAID 0. –  LuxuryMode Dec 21 '10 at 19:37
add comment

2 Answers

up vote 0 down vote accepted

A similar problem happened to me once when I moved windows 7 to a VBOX disk. All I had to do was acquire a windows installation disk image, boot to it, and tell it to "Repair Windows".

If you didn't get a windows installation disk with your computer, you have several options:

  • Ask the place that you got the computer from nicely for an installation disk.
  • Take it to the place where you got it and have them "Repair Windows" for you using the installation disk they used.
  • Download and burn a disk image which matches the installed OS. This should be legal, but IANAL.
share|improve this answer
    
I'm gonna try this. Thanks! Will accept as answer if it works! Always nice to hear an easy solution. –  LuxuryMode Dec 22 '10 at 13:05
    
Bingo. Windows Startup Repair fixed all! –  LuxuryMode Dec 22 '10 at 13:49
    
Glad to hear it! In retrospect, I'd like to point out to the OEMs that the install disk was really meant to be distributed along with every install. It's needed to fix things like this... –  marcusw Dec 24 '10 at 2:15
add comment

I'm not entirely sure about this, but I remember reading somewhere that Windows will freak out and not work unless it's on the first hard disk. Have you tried rearranging things so that it's on the "first" disk? This is a bit of a shot in the dark, but it might help.

share|improve this answer
    
eh? rearranging things? its on the first disk now, no? –  LuxuryMode Dec 21 '10 at 19:44
    
Perhaps...I couldn't really tell from your post, sorry... –  marcusw Dec 21 '10 at 19:50
    
Windows was already installed on the first disk. I simple added a new 3rd drive. So now I have the original dual RAID drives and the 3rd unraided. –  LuxuryMode Dec 21 '10 at 19:51
    
Any way to just get a pro to my house to diagnose this? –  LuxuryMode Dec 21 '10 at 19:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.