Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For example when i want to write 1.1 in MS Word, the . is suddenly converted to ',' when i write the second 1. Here is a illustration of what happens:

alt text

Notes:

  1. I am typing in Arabic and i want the numbers Arabic.
  2. When I am typing in English it is fined and everything went better than expected: The . remains .
  3. I tried to reset Word settings based on the all the ways that MSDN suggests. Now all the styles and options are set to default and all add-ons are removed.
  4. I also tried to reset my Regional and Languages settings to a Standard one. I have also changed all the , separators to .
  5. The problem is with MS Word 2007.

How can i stop the Word from changing my dots to commas? (It only happens when dot is between two digits)

share|improve this question
1  
Have you checked the Regional & Language settings in the Control Panel? –  Remou Dec 21 '10 at 20:09
    
@Remou: yes i did. I explained in the Notes part of the question. –  Isaac Dec 21 '10 at 20:09
    
@Isaac Oops, sorry :) –  Remou Dec 21 '10 at 20:10
3  
Just popping in to say, those are some lovely illustrations. –  Matthieu Cartier Dec 21 '10 at 22:23
    
Reinstalling Word solved the problem (I still don't know why!) –  Isaac Dec 27 '10 at 11:51
show 1 more comment

2 Answers 2

up vote 0 down vote accepted

I just Reinstalled (first Uninstallation and then Installation) and the problem solved.

Maybe Micorosft Office updates caused the problem. Anyway, I am going to only accept security updates for office products.

share|improve this answer
add comment

I know AutoCorrection is in the list, but perhaps all you did was reset them to factory standards: this behaviour that you dislike might be standard. That is why it might be worth a try to look around the AutoCorrect settings and see whether you see this 1.1=>1,1 thing there anywhere in the multiple tabs and lists. In my (older) version of Word, it is under Tools > AutoCorrect. I hope you find this thing, because I can understand it will drive you mad.

share|improve this answer
    
Thanks but i cannot find anything related to this problem in AutoCorrection options. Besides, this is not happening on other computers i have at the office (then it is not a standard behavior). –  Isaac Dec 21 '10 at 21:32
    
Hmm that is strange. And the other computers are also using Word in Arabic? I have three more tentative suggestions. 1. You could try uninstalling MS Office entirely, then reinstalling it. 2. I still have the feeling that this is very typical for AutoCorrect misbehaviour, but you say you looked into that already. Have you tried unchecking all the relevant boxes in AC? There might be some box that taps into another list of corrections. 3. In AC, you could set up a new "Replace 1,1 with 1.1", just to see what that does... –  Cerberus Dec 22 '10 at 0:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.