Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Excel 2007 on Windows 7 64-bit. I need to run Excel as administrator so I have the "Run as Administrator" box in the Excel shortcut checked.

Now, when I try to open an Excel file by double clicking, I get the following error:

There was a problem sending the command to the program

Excel opens fine after that, and I can open the file fine through Excel's File/Open menu.

Why can't I open the file by double clicking? Some sites suggest changing a specific Excel option. I tried while checking/unchecking Excel's "Ignore other applications that use Dynamic Data Exchange (DDE)" but that didn't help. The issue goes away if I uncheck "Run as Administrator" but I want to be able to leave that checked.

Any ideas?

share|improve this question
    
Only thing I can figure is Due to the security features of Office, running in administrator mode cripples some security features, so you may have to live with that error message. I can find no documentation on this though, I have Office 2010, it behaves the same way no matter what I do when running as administrator. Please post if you figure it out. –  Moab Dec 22 '10 at 3:09
2  
Excel and the Windows shell (explorer.exe) are operating in slightly different security contexts given that one process is running elevated and the other is not. I can't verify this but it might be that this difference in privilage levels is preventing propper communication between excel and the shell –  Crippledsmurf Jan 11 '11 at 3:31
    
I have this same issue with Win7 (64bit) and Office 2003 version of Excel. I had previously selected "run as administrator" for Excel, when I unchecked that option the issue disappeared! Thanks for this posting! –  user82196 May 20 '11 at 15:30
add comment

3 Answers 3

The problem is that Excel files are by default opened with DDE (by sending a message to the Excel window). If you run Excel as Administrator, your Explorer process which is running as a normal user will not have the privilege to send messages to the former. This is a correctly implemented security feature.

It is generally a very bad practice to run programs like Excel as Administrator because MS Office files are common targets for viruses. If you want to access some protected file, just explicitly grant your current user "modify" access to that file/folder.

share|improve this answer
add comment

Running compatibility mode for XP did not work. Nothing has fixed this issue as of yet.

If you need to run an Excel sheet as an administrator for VBA code reasons or other reasons and you are using Windows 7, you are basically screwed. You have to run as admin, then when the error comes up you have to open the workbook manually from the file/menu.

That's the only workaround as of now.

share|improve this answer
add comment

I have Office 2010 on a Windows 7 64-bit system and cannot duplicate your issue. Maybe because I am an administrator? Maybe it's specific to Office 2007 ?

Anyways, have you tried this?

For people who DDE solution fails try this:

If you have Windows 7 32 bits go to program files --> microsoft office --> office 12 (or if you have office 2010 then go to office 14) --> right click on EXCEL.EXE --> choose Properties, then click on Compatibility tab and if you have anything checked in that tab uncheck it.

If you have 64 bits then instead of program files go to 'program files x86', the rest is the same.

Found it posted here.

alt text

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.