Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday I got win32.Saltiy virus and did some damage before my Kaspersky suite caught it. Now I've cleaned all the viruses using Kaspersky but I believe the changes it did to the registry/policies are still there.

I'm not able to have write access on the entire file system. It is showing up the access denied the error. I'm in the local system administrators group. I've tried removing and re-adding it (with a reboot). But still no luck.

Any ideas on how can I fix this?

share|improve this question

3 Answers 3

I hope this provides something you have not already tried and is useful.
Is the administrator account still active for your account,virus not changed
Logon as adminstrator by way of cmd-active,etc
Has any encyption been turned on.
Have you checked that the loacl security policy/ group policy has not been changed.
Do you have a system restore point that will take you back before the virus, if it is your registry that has been changed then a restore could help.-hope something works.
This site explains how to access the contents of your system restore,this could tell you if changes have happened.
http://www.sepago.de/helge/2007/12/19/why-vistas-system-restore-is-dangerous-and-what-to-do-about-it/

share|improve this answer

Have you tried to take ownership of the files and then assign your permissions again?

share|improve this answer
    
Thanks for the link. Tried it with no luck, though. –  NLV Dec 23 '10 at 11:26

In fact it was not the virus that caused the trouble. I detached my lap from the domain couple of days ago and reattached it. That was the problem. I again detached it and reattached to the domain today and it solved all the issues.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.