Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently I've bought a Sony Reader PRS-600 and an HP iPaq which charge via USB.

At times, I can't make it start recharging when it's connected to the computer. The indicator on my Reader lights up and the icon in the system tray appears. They both show that the Reader is plugged in. However, the device should start recharging and allow me to browse through the files. But it doesn't.

This happens on both my desktop and laptop, both running XP SP3. What interest me is that occasionally I can I just plug them in and they work properly.
There are even some computers (I have tested quite a few possibilities) on which the problem does not appear!

My question is are there any tools that could help me diagnose USB ports? Or maybe someone knows the solution?
I have a lot experience with low level programming (mostly from the times of MS-DOS applications), but I'm not an expert when it comes to Windows XP. I know how to track network traffic, but with USB ports I feel powerless.

I have a feeling that the problem may lie in the way WinXP handles USB devices. I know that somebody will suggest to move to Linux or other *Nix system, but XP is a major part of my professional life. Besides, I don't consider XP as a total disaster.

Any help from you will be appreciated!

share|improve this question
Does it happen more frequently when the devices batteries are low on power? – Mokubai Dec 22 '10 at 15:57
@Mokubai: Yes, it does. When the ereader has run out of power, it can hardly be revived. – Lukasz Dec 22 '10 at 21:01
up vote 2 down vote accepted

One of the problems with Lithium battery devices is that when the battery is quite low they tend to have a much higher charging current and what I suspect is happening in your case is that all the current from the USB port on your computer is being sunk straight into charging the battery and not enough power is being "held back" to allow the device to work properly.

In expensive chargers in devices, they tend to have some intelligent design that means that when you want to use and charge the device at the same time the power gets split down two paths with the device itself taking what it needs and the battery getting the rest. I suspect that what you have is not that well designed.

In the cheaper devices the battery charger circuit and the rest of the device are simply tied together with both parts trying to get what power they can, the problem is that when the battery is very low the battery can sink very high currents from the charger and so this is likely stealing all the power it can and preventing the rest of the device from powering up properly.

As a test, try leaving the device plugged in to you computer for half an hour to an hour, if after then it seems to be able to start up as you'd expect then I'd say this "cheap" charger circuit is the likely culprit.

Some devices also have a dual power inlet for exactly this purpose, to provide all the power needed for the charger circuit and the actual device to work fully at the same time.

As to an explanation about why it works on some machines and not others, it is very possible that the USB ports on some machines don't output quite as much current as they should and some others are much more forgiving of devices that draw a high current, not all motherboards are created equal in this respect.


As another side note, lithium batteries generally have longer lifespans if they do not go through deep discharge cycles, from everything I've seen about them the rule seems to have been charge them as often as you can. A deep discharge is good once in a while, and you shouldn't worry too much about it, but it's not as necessary as the old NiCad and NiMH batteries we used to use.

share|improve this answer

Another reason they call it "plug and pray", USB issues like this are extremely difficult to track down most of the time.

One trick I use is to connect the problem devices using an external usb hub, sometimes this gets them working in Windows and is a mystery to me why.

Sometimes it is a conflict with another USB device that is also connected.

Sometimes updating the chipset driver will cure USB problems, Intel says this isn't so, but I cannot count how many PCs I have cured weird USB problems using this method on systems with Intel chipsets.

You can also look in device manager while the problem device is connected, see if there is any error messages, but this usually does not help solve the issue, just confirms there is a problem.

Worst case you have to do a repair or clean install of the OS and drivers.


share|improve this answer
thank you for the answer, I've also thought of using USB hub. I'm going to give it a try. I'll post info here if it helps. I've investigated device manager and tried to uninstall/re-install drivers, but with no success. – Lukasz Dec 22 '10 at 15:43
Another suggestion here, be sure your PC is set to boot into the desktop without any user input before you do as suggested in this – Moab Dec 22 '10 at 22:42

Maybe it could help to delete all usb devices within the device manager and reinstall them. I had sometimes troubles with some usb devices and this fixed it for me.

Another "debug" could be msinfo32. Maybe you can get some informations there.

share|improve this answer
thanks, msinfo32 is quite useful, although it doesn't solve the problem – Lukasz Dec 23 '10 at 8:20

You need to investigate this more. Take the HP IPAQ PDA for example. There are many ways you can charge that. With a car charger. With a plug in the mains. With USB. If it is not charging, not flashing, then you should investigate it while it is acting up. Quickly switch it to a mains-plug charger. Do you find it ever act up with a plug charger?

Regarding it not getting recognized. I often found that when plugging it in, it didn't get recognized. I bought a new cable and the new cable was very reliable.. It was a cable thing. But these things can be combinations of cable and usb port.

If you have a really reliable cable then it can compensate sometimes. Like, unrelated to this, i've had a usb adaptor that works in some comps and not others. And another usb adaptor that works in all the comps. So, I conclude that it's both usb device and usb port come together to make an issue, each contributes to it. you can't do much about the usb port. And in your case, not much about the device. But you can about the cable!

It is not uncommon for an HP IPAQ to not be recognized on USB, then people get a new cable and it is. Get a nice official looking cable if you can! And since they're cheap.. you can buy a few from a few people,and a shop.. Will they all have the same problem, then maybe not the cable. You could start with one cable.. it's definitely a good move.

share|improve this answer
Well, HP IPAQ works very good when it's charged with its normal charger (the one that's plugged in 120/230V socket). That's why I'm not complaining about PDA. There is no other option to recharge Sony Ereader - there was no other recharger included. And it is also not a problem with cables, becuase I tried other original cables and it didn't help. – Lukasz Dec 22 '10 at 16:32
so do you think your charging problems are because every usb port on both your desktop and your laptop, is a malfunctioning a bit and in the same way? or that both your PDAs are malfunctioning to different extents, in the same way, in relation to charging? The only further tests I can suggest with this are more computers and/or more PDAs! – barlop Dec 23 '10 at 4:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .