Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

So I have a table in MS Word which has two columns. In the second column the text is spread on multiple lines, ie I have pressed 'Enter' to achieve this.

When I paste into Excel, it converts these separate lines into separate cells.

What I want it to do is to keep the lines in the same cell, just on different lines, ie what would happen if I were to press Alt+Enter in a cell in excel.

How would I go about this?

Edit: here's an example of my data. In word it's in a word table.

| Bananas   | - yellow     |
|           | - curved     |
| Apples    | - red/green  |
|           | - round      |
share|improve this question

marked as duplicate by Excellll, Steven, fixer1234, nc4pk, mdpc Jul 22 '15 at 6:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

in word how are the cells separated? also with [enter] ? or is it in a word-table? – madmaze Dec 22 '10 at 16:56
It's a word table. – Sean McRaghty Dec 22 '10 at 19:30

Better answer: How do I copy Word tables into excel without splitting cells into multiple rows

The trick given is to copy/replace newline character in the Word table with something like the paragraph symbol ¶ (now I know that's also known as a "pilcrow"). You don't have to save the Word document to preserve your original.

Paste the modified data into Excel and then you can do another copy/paste to put the internal line breaks back inside the cells without splitting them. The gimmick on the Excel side is using Alt-codes to define the search and replace. See the referenced link.

share|improve this answer

Pasting won't work. Alt+Enter in Excel isn't a special character, it's only a way of ensuring a CR+LF is stored within a cell rather than forcing you into the next cell.

One option would be to not press Enter in your Word table but use another character instead (e.g. '#') and then use a macro in Excel to search for '#' and replace with CHR(10) once you've pasted.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.