Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I click on System Preferences > Accounts, I get a crash [every single time].

Here are a few interesting snippets from the "Problem Report".

Any ideas on how to tackle this?

Process:         System Preferences [607]
Path:            /Applications/System Preferences
Version:         7.0 (7.0)
Build Info:      SystemPrefsApp-1750100~5
Code Type:       X86-64 (Native)
Parent Process:  launchd [184]

OS Version:      Mac OS X 10.6.5 (10H574)

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000117547860
Crashed Thread:  0  Dispatch queue:

Application Specific Information:
objc_msgSend() selector name: willSelect
objc[607]: garbage collection is ON

Thread 0 Crashed:  Dispatch queue:
0   libobjc.A.dylib                 0x00007fff80fd211c objc_msgSend + 40
1     0x0000000100008426 0x100000000 + 33830
2     0x0000000100006fb8 0x100000000 + 28600
3            0x00007fff84ede23c __NSFireDelayedPerform + 404
4        0x00007fff824acbe8 __CFRunLoopRun + 6488
5        0x00007fff824aadbf CFRunLoopRunSpecific + 575
6             0x00007fff82ec691a RunCurrentEventLoopInMode + 333
7             0x00007fff82ec671f ReceiveNextEventCommon + 310
8             0x00007fff82ec65d8 BlockUntilNextEventMatchingListInMode + 59
9                0x00007fff866c0e64 _DPSNextEvent + 718
10                0x00007fff866c07a9 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 155
11                0x00007fff8668648b -[NSApplication run] + 395
12                0x00007fff8667f1a8 NSApplicationMain + 364
13     0x0000000100001cf4 0x100000000 + 7412


Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000001  rbx: 0x0000000200037840  rcx: 0x0000000200058031  rdx: 0x00007fff5fbfe2c0

Binary Images:
       0x100000000 -        0x10001eff7 7.0 (7.0) <30C04F1A-7711-1359-8A0E-D707B8BF2EB4> /Applications/System Preferences
       0x100758000 -        0x10076dfff 10.6.4 (10.6.4) <4711F2E8-DFA5-4C81-BB2A-B1E39D5B1B91> /System/Library/PrivateFrameworks/OpenDirectoryConfigUI.framework/Versions/A/OpenDirectoryConfigUI
share|improve this question
Is there another account already created that you can open System Preferences in ? – CaseyIT Dec 22 '10 at 19:52
Disable or remove Input Managers and processes running in the background. Check to see if other applications or preference panes crash. Have you recently installed software using an installer, software that required your admin password, or hardware drivers? – Daniel Beck Dec 23 '10 at 4:20
no unfortunately there is not another account I can try this on. I've installed a bunch of stuff recently. I tried removing all the preference panes, but am still seeing this. – Vivek Sundaram Dec 24 '10 at 1:08
Can anyone help decipher the call stack to see where the problem might be? – Vivek Sundaram Dec 24 '10 at 1:08

Since System Preferences is generally rock-solid and stable, I'd bet the problem has to do with something filesystem-level. Try doing a permissions/disk repair from Disk Utility.

Is there anything weird about the accounts that exist on your machine? Did this start to occur after any particular recognizable event?

If all else fails you might need to reinstall OS X, but you should be able to migrate your Applications and user accounts pretty seamlessly.

share|improve this answer
Tried the permissions/disk repair command. No luck. I'd prefer not to do a re-install. Also I have installed a bunch of stuff, but don't remember exactly when this started happening – Vivek Sundaram Dec 24 '10 at 1:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .