Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Leading up to the problem: I was working late one night on a Keynote presentation. My battery ran out, and the computer did that hibernation thing it does when there's no battery power. I got my charger, connected it to my computer, and then pushed the power button. It started up for a second in to the gray screen it usually goes to. Then I turned around, tugging the magsafe charger out of the connector on the computer. This caused my computer to shut down again. Now I can't get it to boot at all -- just a blinking folder icon with a question mark in it on boot up.

I've tried pretty much everything to deal with this. Multiple forced reboots, resetting PRAM and NVRAM, etc. I booted to original OSX disc and ran disc utility, but I discovered that there is no disc to boot to.

I ran the Apple Hardware Test, and it came back 100% good. I booted to an Ubuntu live-boot disc and ran that disc utility, just to see if it recognized a disc at all. It didn't. So I removed the HDD, and replaced it with a bootable volume running BSD. It didn't recognize that HDD either. I then attached my HDD to my computer via an external enclosure with a USB interface. Lo and behold, it booted!

So my computer now only work with my HDD attached externally. This means that the HDD is functional. And the AHT returns no hardware malfunctions. So what the hell is going on?

In the meantime: I've put the HDD back into the computer but it still doesn't do anything at all (I'm running it externally right now). I just checked the serial number and my 1 year warranty expired recently, so I can't send it back for repair.

Little Help Thoughts? I've been searching everywhere for leads, but no luck.

share|improve this question
    
+1 Thats just crazy. –  Moab Dec 22 '10 at 21:37
    
Maybe the motherboard socket went bad. Did you use different ports on the HDD when you plugged it in externally? That could mean that the pins are bent. If you have another HDD, try slapping it there and see what happens... Good Luck. –  David Dec 22 '10 at 22:05
    
So I removed the HDD, and replaced it with a bootable volume running BSD. It didn't recognize that HDD either. -- says it all. I'm with @madmaze here. –  Daniel Beck Dec 23 '10 at 4:22

1 Answer 1

Sounds to me like your sata controller for the HDD may be fried or damaged.

Sometime the connectors themselves fry

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.