Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed Windows 7 recently, and I expect that it would alter GRUB and it did.

I've been following some guides around and I am always stuck at GRUB not able to detect the usual RAID content. (Software RAID 0)

I've tried running:

sudo grub

> root (hd0,0)

GRUB complains it couldn't find my hard disk. So I tried:

find (hd0,0)

And it complains that it couldn't find anything.

So I tried:

find /boot/grub/stage1

It said "file not found".

Here's the text from the console:

ubuntu@ubuntu:~$ grub
Probing devices to guess BIOS drives. This may take a long time.

       [ Minimal BASH-like line editing is supported.   For
         the   first   word,  TAB  lists  possible  command
         completions.  Anywhere else TAB lists the possible
         completions of a device/filename. ]
grub> root (hd0,0)
root (hd0,0)

Error 21: Selected disk does not exist
grub> find /boot/grub/stage1
find /boot/grub/stage1

Error 15: File not found

So what now? How can we make GRUB see RAID 0 under Ubuntu 10.10 LiveCD?

share|improve this question

Is it a software raid or an hardware raid?

Take a look at this -> http://forums.gentoo.org/viewtopic.php?p=2053048

share|improve this answer
    
This is software RAID 0. – Karl Dec 24 '10 at 4:18
    
I have tried in the link provided. It is very similar to what I did before. Nope, it doesn't work. – Karl Dec 25 '10 at 5:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .