Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

Currently my Windows 7 computer is crashing during startup, after loading the AMD achix64s.sys driver, if I enable BIOS AHCI mode for the disks. It boots fine with IDE mode.

Since I need my computer working, I am wondering if I can just use IDE mode for now, and later change to AHCI mode, when I figure out what is wrong.

Background: I was running RAID mode, which needed additional drivers to install/boot Windows. But the MoBo RAID is flaky so I'm trying to switch to using a Windows mirrored volume instead - for that I expected to use AHCI mode.

share|improve this question

marked as duplicate by Oliver Salzburg Oct 15 '13 at 21:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

3 Answers 3

up vote 11 down vote accepted

What neurolysis says USED to be the case. In practice, I cut this on all the time in Windows 7 - it's painfully simple and non-complex compared to Windows XP to go from IDE to AHCI.

If you want to change 7 from IDE to AHCI, all you need to do before you change the BIOS setting is look in the registry at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci and change the 'Start' key to 0. (If an AHCI driver has never run on this machine it's probably 3.) The first time the machine boots in an AHCI controller mode it should load the default AHCI driver properly and prompt for a reboot.

Note, however, that depending on your drivers and controller the REVERSE is not always true - it may work just fine if you change from AHCI to IDE, or you may get bluescreens. (I've never had occassion to fix one of those so I couldn't tell you how.)

EDIT: I would just add that I have no experience with this in Vista but I suspect it works much like 7. In XP, changing this is a huge undertaking that involves a major registry hack tailored to your specific hardware, and a reinstall is almost always simpler unless you're going to be doing a dozen identical machines or so.

DOUBLEEDIT: There is a very minute chance of failure here in the event that you have a really strange motherboard that won't work properly with the default MSAHCI driver and will ONLY use its own. Try installing it first if that's the case. (I have done this on dozens of current-gen boards and NEVER seen one that wouldn't run with the baked in driver, and in fact it benchmarks very well.)

share|improve this answer
    
Thanks, I will try this. Before I do, any thoughts on the fact that I was running these in RAID mode yesterday? –  Lawrence Dol Dec 23 '10 at 15:25
    
@Software Monkey - Oh, somehow I overlooked that little tidbit. Depending on your RAID controller it may or may not be an issue, but I'm guessing probably not. What's wrong with running in RAID in the first place, though? You get basically the same functionality as AHCI. Does this board have a separate RAID controller or something? –  Shinrai Dec 23 '10 at 15:26
    
@Shinrai: I was running RAID, with my two data disks in a RAID-1 mirror; but it's flaky and has several times now complained that one or other of the disks has failed when it hasn't. In RAID mode it insisted that I had a broken array, and threatened me with blanking the disks if I deleted the array. I have since deleted the control partition via Windows disk manager in IDE mode, so that RAID array is now moot; but I don't want to continue with RAID on this mobo. –  Lawrence Dol Dec 23 '10 at 15:35
    
As importantly, I have received no indication of a problem while running, only at the next boot - this last time I have concrete evidence that the array stopped writing to one of the disks earlier in the day (from several files which I had created), but was completely unaware until I rebooted for an unrelated networking issue. Both disks have checked out in every way, so I am very confident that there is no actual hardware problem with them. –  Lawrence Dol Dec 23 '10 at 15:37
    
Ahh, that makes sense. Agreed - give AHCI a go. –  Shinrai Dec 23 '10 at 15:50
show 2 more comments

As far as i know you need extra drivers when you switch from ide to ahci and vice versa.

After i changed this i had to do an repair install. Later i found this, but wasn't able to test it -> http://www.ithinkdiff.com/how-to-enable-ahci-in-windows-7-rc-after-installation/

share|improve this answer
1  
Your link works, I can verify from experience. (Also, see my answer. ;) Heh.) –  Shinrai Dec 23 '10 at 15:17
    
@Shinrai: Thanks for that :) –  patricks Dec 23 '10 at 15:24
add comment

It's possible, but inadvisable. Switching the disk mode without reinstalling the operating is a primary cause of problems at an operating system level (often it refusing to boot), because it expects one way of functioning and gets another. It is, of course, possible to go change everything that expects the disk to be IDE to expect it to be AHCI, but I really wouldn't recommend it, especially on Windows.

share|improve this answer
1  
This isn't a problem with 7 anymore - see my answer. –  Shinrai Dec 23 '10 at 15:17
    
Interesting. Thanks for the info! –  Matthieu Cartier Dec 23 '10 at 15:50
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.