Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using MikTeX 2.9 on Windows 7, and when I want to create my pdf file I get:

! Package hyperref Error: Wrong DVI mode driver option `dvips',
(hyperref)                because pdfTeX or LuaTeX is running in PDF mode.

How can I fix this?

share|improve this question

migrated from stackoverflow.com Dec 23 '10 at 15:31

This question came from our site for professional and enthusiast programmers.

2 Answers 2

It sounds like you've asked the hyperref package to work in dvips-mode, but are trying to compile it through pdfTeX.

My guess would be you either:

  • Have set the option dvips in your \documentclass. An example of this would be:

    \documentclass[dvips]{article}
    
  • Have set the option dvips in your \usepackage for hyperref. An example of this would be:

    \usepackage[dvips]{hyperref}
    

If you're doing either of those two things, you're actively telling the package that you're using dvips, which you're not, so it's failing.

You should be able to resolve the problem by either:

  • Removing dvips from the options list.
  • Replacing dvips with pdftex.

If none of these options are set, try setting the pdftex option on your \usepackage{hyperref}.

share|improve this answer

In my case, I just had to use a decent TeX Editor, as WinEdit.

I run texify to create a .dvi file and then dvi2pdf.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.