Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm not seeing the Sharing option in System Preferences. Here's a screenshot of my System Preferences:

   My System Preferences application

I'd like to disable the Web sharing option so that I can start Apache.

I'm on an iMac running Mac OS X 10.6.4 (10F569).

share|improve this question
add comment

migrated from stackoverflow.com Dec 23 '10 at 20:29

This question came from our site for professional and enthusiast programmers.

2 Answers

A few possible solutions to try:

  1. The easiest is to download and install the Mac OS X v10.6.5 Update. Since you're running 10.6.4, you might as well update anyway, and it's likely this will restore the missing pref pane.

    However, before doing this, I recommend that you attempt to repair permissions using Disk Utility.

  2. Delete your preferences. Open Terminal and type the following two commands, then restart:

    cd ~/Library/Caches    Enter

    rm com.apple.preferencepanes.*    Enter

  3. Create a new user account and log in to your Mac using that account instead. See if the missing preference pane appears when you are logged as a different user.

  4. If you happen to have another Mac around (running the same version of OS X!), you could copy the pref pane from that one to yours. You'll find it here:

    /System/Library/PreferencePanes/SharingPref.prefPane

    If no other Mac is handy, you can use Pacifist to extract the appropriate preference pane from your OS X Install DVD and restore it.

  5. Finally, just in case, are you running Apple Remote Desktop (ARD)? This software modifies your Sharing preference pane. Try upgrading your ARD client.

share|improve this answer
add comment

Install the Mac OS X 10.6.5 Combo Update.

This method is more comprehensive than a simple 10.6.4->10.6.5 update and will more likely fix your issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.