Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

i am setting up a linux virtual machine (windows 7 64 bit host, ubuntu 64 bit guest, using virtual box) and i just installed drop box and set it to sync. I've only got about 2Gb in there so i figured it should take just an afternoon, but it's going at about 0.5 kB/second and says it will take about 60 days.

I usually get about 200 kB/second in the host OS, and downloading straight from the dropbox website through firefox in the ubuntu VM i get about that, but sync is really slow.

any tips?

share|improve this question
    
using the "selective sync" function to uncheck some of the folders with thousands of very small files seemed to help, but it's still only going at about 2.0kB/second –  Kirstin Dec 24 '10 at 6:22
    
Did you set your ubuntu virtual drive's file to expand as necessary? Or did you pre-allocate the full drive size? If you did the former then you could be seeing VirtualBox expanding the drive file as new files are pulled down from DropBox. (I don't know how quick the VirtualBox drive file expansion is.) –  Mike Chess Jan 7 '11 at 23:56
    
i set it to expand as needed, but it doesn't seem to have a problem with that slowing it down most of the time. It's not slow to save large files, and seems to handle large numbers of files being automatically created by other programs just fine. –  Kirstin Jan 24 '11 at 1:44
add comment

2 Answers

up vote 1 down vote accepted

when trying to do a lot at once (e.g. installing dropbox on a new machine and syncing to an already full account) it seems it goes much faster (up to 100x faster) if you use the "selective sync" function to sync a few files/folders at a time.

They must ration bandwidth on the free accounts and throttle it if you try to move a lot at once, but it seems if you're willing to baby-sit it and do it a folder at a time you get normal speeds.

share|improve this answer
1  
There is no throttling involved with free accounts. The reason why you may be experiencing this problem is because Dropbox first synchronises your small files first, moving on to the larger files. This solves the issue of all your small to medium files queuing behind larger ones. –  emtunc Jan 22 '11 at 22:34
    
could it be that i had a few thousand tiny ones so when i took that folder off the list it got quicker? is there a time/file factor as well as a time/Mb? –  Kirstin Jan 24 '11 at 1:38
    
also, where is that selective sync option? i found it last time but i can't find it again. –  Kirstin Jan 24 '11 at 1:39
    
Late but here is the answer: dropboxwiki.com/tips-and-tricks/… –  kontinuity Jul 11 '13 at 8:07
add comment

I moved my dropbox folder from home (which is encrypted) to a non encrypted location and the upload speed increased massively, hope this helps

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.