Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a reliable way to troubleshoot laptop wakes? I've seen "heuristics" posted here and there but isn't there really a simple and deterministic way to tell what's causing a problem?

Specifically, my laptop wakes up about every hour for about 2 minutes. Exported event log entries are here: http://www.mediafire.com/?abcqb00v5wyo6pj.

I've tried:

powercfg -devicequery wake_armed

Empty result set.

Scheduled tasks - the main ones are not scheduled to run every hour. When go through a long list of all possible tasks, there are some that are set to be triggered every hour (e.g., MS "RacTask" whatever it is). But when I go to power options, Advanced settings, Sleep, Allow wake timers it is set to "Disable". Also, the specific task is not set to wake the computer if necessary.

Power options for my Ethernet card don't enable it to wake the computer - the cable is disconnected anyway. There are no other HW devices attached - no USB disks, no keyboards / mice etc. I am really clueless and quite unhappy that it's so hard to troubleshoot this situation.

share|improve this question

2 Answers 2

There are (generally) three locations that configure WOL capability.

  1. BIOS. Depending on your BIOS you may have advanced options beyond a simple enable/disable option.

  2. Windows power management options.

  3. Power management options of the device itself.

If you are trying to completely disable WOL, verify that it's disabled in the BIOS.

share|improve this answer

Resume is tough to troubleshoot sometimes, usually it is a 3rd party driver or software that is causing the problem, not a windows system driver, task or software. Use msconfig to disable Non microsoft items under startup and services tabs, see if it cures it. If it does re-enable them one at a time until the problem comes back, then you have the culprit.

You can also check device manager under network, check the properties of each network adapter, go to the power management tab and be sure the box "allow this device to wake the computer" is Unticked. Do this for all adapters present.

. alt text

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.