Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have iCal syncing with a Google Calendar account, and for some reason, some meeting invites that I accept wind up with an email alarm set for 10 minutes before the meeting. This causes iCal to send me an email through Mail.app at the appointed time.

This is a pain in the neck, because Mail.app launches if it's not open (and since I use a different client, it never is), and if I'm offline, Mail.app starts throwing up error messages. And besides, I don't want meeting alarms in my inbox.

Is there any way to completely disable email alarms in iCal? The only option I see is "Turn off all alarms" - but I don't want to turn off the pop-up windows, just the emails. I remove those alarms any time I come across them, but sometimes they slip through.

share|improve this question

3 Answers 3

Login to your Google account, click on the triangle next to your calendar name and select Notifications.

In there you probably have the the default reminder under Event reminders. Delete it.

share|improve this answer
    
The problem with this is when you are sharing from someone else's calendar; they may have notification emails set. –  Jordan Reiter Jun 26 '12 at 20:32

I've had the same problem using iCal with Google Calendar and Sparrow.

While there does not appear to be an option to diable only iCal's email notifications, you can disable both email and desktop notifications. In the advanced tab of iCal's preferences, select "turn off all alarms". If you don't care about iCal desktop notifications, you're all set.

If you do want desktop notifications, you may need to look into an additional app. I found CalendarBar worked for me. I already used it for quick access to my day from the menu bar. But it can push notifications to you desktop via Growl. There are probably other apps that can do the same thing, I just used what I already had on hand.

share|improve this answer

From: https://apple.stackexchange.com/questions/46024/how-do-i-stop-email-reminder-from-ical

For Mac OS X Mountain Lion 10.8.0:

  1. Click on the "Calendars" button on the main window to show the sidebar of calendars.
  2. Right mouse click on the calendar you want to ignore alerts from & choose "Get Info"
  3. Check ON "Ignore Alerts" & click "OK"
share|improve this answer

protected by nhinkle May 13 '11 at 5:34

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.