Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using MTS datacard. I have usb_modeswitch installed and have configured the wvdial.conf file. When I do sudo wvdial cdma, the IPs and DNS addresses are also allocated but I still cant access internet. The reply to dmesg | grep -e 'tty' -e 'modem' is:

[0.000000] console [tty0] enabled

[11.098238] USB Serial support registered for GSM modem (1-port)

[11.098352] option 6-1:1.0: GSM modem (1-port) converter detected

[11.102170] usb 6-1: GSM modem (1-port) converter now attached to ttyUSB0

[11.102207] option 6-1:1.1: GSM modem (1-port) converter detected

[11.102334] usb 6-1: GSM modem (1-port) converter now attached to ttyUSB1

[11.102364] option 6-1:1.2: GSM modem (1-port) converter detected

[11.102488] usb 6-1: GSM modem (1-port) converter now attached to ttyUSB2

[11.102522] option 6-1:1.3: GSM modem (1-port) converter detected

[11.102643] usb 6-1: GSM modem (1-port) converter now attached to ttyUSB3

[11.102672] option 6-1:1.4: GSM modem (1-port) converter detected

[11.102793] usb 6-1: GSM modem (1-port) converter now attached to ttyUSB4

[11.103074] option: v0.7.2:USB Driver for GSM modems

Can anyone tell me what shall I do?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

well, after a lot of googling, I found that the DNS entry that should have been made be the network-manager wasn't made. so, I had to manually do that by editing the /etc/resolv.conf file and restarted the network.

# Generated by NetworkManager


# No nameservers found; try putting DNS servers into your
# ifcfg files in /etc/sysconfig/network-scripts like so:
#
nameserver 8.8.8.8
nameserver 8.8.4.4
# DOMAIN=lab.foo.com bar.foo.com

This solved the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.