Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having a problem with Ubuntu that I'm finding hard to troubleshoot for reasons that will become clear:

reboot

-bash: /sbin/reboot: Input/output error

dmesg

-bash: /bin/dmesg: Input/output error

ps -e

ps: error while loading shared libraries: /lib/libproc-3.2.8.so: cannot read file data: Input/output error

lsof

-bash: /usr/bin/lsof: Input/output error

fsck

-bash: /sbin/fsck: Input/output error

badblocks

-bash: /sbin/badblocks: Input/output error

So I can't see what is going on, and I can't remotely reboot. What can I do to get to the bottom of this?

Interestingly:

init 0

Segmentation fault

I can cat /var/syslog but not /var/log/messages or several other important files. less and more don't work, neither do tail or head, etc.

share|improve this question
    
Sounds pretty similar to what you get after running sudo rm -rf /. (I did it on purpose, just to see what actually happens.) –  AJMansfield Sep 12 '13 at 19:27
add comment

1 Answer

up vote 4 down vote accepted

The system is having severe trouble reading off of your hard disk. It's likely that the disk is dead (almost certain), but it could be something as simple as a loose/disconnected cable (don't count on it). There isn't anything you can do to troubleshoot it from here. Just power it off.

Check for loose connections on your hard disk. If everything is fine there boot from a rescue disk and run fsck or badblocks from there.

I hope you have a back up.

share|improve this answer
1  
The weird thing though is that when I was able to physically reboot the machine and did so, it came back on seemingly with no problems. I still have not found any problems, though I am taking this as a warning sign that the disk is not reliable and could go at some point. I do keep my all my important files in at least two places using git, so at least that wouldn't have been a problem. –  rplevy Jan 3 '11 at 1:51
    
Then it is possible that it was just a communication error (e.g., loose cable). Keep an eye on it though. Once a disk starts to fail it's usually completely dead soon after. –  bahamat Jan 3 '11 at 5:54
    
The same happened to my virtual machine. Once rebooted it started working fine. –  droope Nov 29 '12 at 20:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.