Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've checked the error logs for this particular problem and it seems no access can be made to port 80.

(OS 10013)An attempt was made to access a socket in a way forbidden by its access   permissions.  : make_sock: could not bind to address [::]:80

Turning the Windows firewall off didn't work, so I'm a bit lost. All of this is running on my laptop so I don't have my own "server" per se but I was under the impression that this would work without the need for one independent of my own personal computer. How would I solve this?

share|improve this question

migrated from stackoverflow.com Dec 26 '10 at 13:44

This question came from our site for professional and enthusiast programmers.

3 Answers 3

If its windows, port 80 would be already assigned to IIS (if installed). Check if IIS is installed stop IIS and retry else change the port number for apache in httpd.conf file to 81 or any other value.

share|improve this answer
    
How would I check to see if an IIS is installed? –  nogamo Dec 25 '10 at 17:55
    
just type localhost in a browser to see if you get a response back and if its IIS you easily find it out. –  Chandu Dec 25 '10 at 17:56
    
I believe there was one installed even though localhost did nothing for me. In the Windows Features window there was an Internet Information Services thing checked, so I unchecked it. Doing that fixed the problem. THANK YOU. –  nogamo Dec 25 '10 at 18:11

Ensure that Skype is not using the port as it sometimes uses port 80 by default. You can change that behaviour in Tools -> Options -> Advanced -> Connection and unticking the box to use port 80 and 443 for incoming connections.

Alternatively, you can also see what ports are currently being used by launching a command prompt and entering:

netstat -ab

This will tell you which currently open programs are using which ports.

share|improve this answer
    
I have done this and the problem persists. Upon checking the port it says that Process: System is using the port. I'm not sure if I've even installed an IIS, and if I have (or one is on Win7 by default, I don't know how to check). –  nogamo Dec 25 '10 at 17:48
    
Are you sure that apache isn't already running as a service then? Try pointing your browser to localhost and see if you get a response. –  andre Dec 25 '10 at 17:50
    
No response, just a broken link. The XAMPP Control Panel says that Apache is starting, but it never states that it is "Running" in the same way the mySQL is. –  nogamo Dec 25 '10 at 17:53
    
Start menu -> Run -> services.msc - Look for services that may be using port 80 (IIS, etc) and shut them down, trying to launch apache as you go. –  andre Dec 25 '10 at 17:56

have same problems with WAMP. How i understand this problem appears if other application took this port before.

Firstly, try to change Skype port from 80 to another in settings. Its help me.

try this http://www.tjkdesign.com/articles/Apache_and_WAMP.asp

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.