Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to get an mac mini running snow leopard server to join a windows domain here. The windows domain server is running Windows server 2008.

When I go to "Accounts" in my System Preferences, and lick on "Join", I get this error: "Unable to add server. Node name wasn't found. (2000)"

In my console messages I find this:

10-04-06 11:42:25 AM System Preferences1452 -[ODCAddServerSheetController handleOtherActionError: gotError: Error Code=2000 UserInfo=0x2004f2f80 "Custom call 82 to Active Directory failed.", Node name wasn't found.

I specified a FQDN for the domain server, so I am totally confused as to why it would list "domain =" in that error.

I've tried firing up the Directory Utility and trying to join a domain via the Active Directory option there. Again I fill in the FQDN, and the proper administrator/password acount info. Now I get a different error:

"Invalid Domain

An invalid Domain and Forest combination was specified. You should enter a fully qualified DNS name for the domain and forest (e.g.,"

If anyone has any pointers or suggestions this would be appreciated.

share|improve this question
Error means that is where the error originated, not what domain you typed in. Error and Domain in this context are contiguous. Also, try to bind to AD using the directory utility located in /System/Library/CoreServices/Directory – C0D3M0NK3Y Sep 3 '11 at 3:37

The AD domains are discovered by looking at DNS. There is a resource record added for _ldap._tcp.dc._msdcs for each domain you have an AD domain.

Make sure your OS X box can resolve these DNS entries.

share|improve this answer
Achieve this by statically setting your primary DNS address in Networking to the address of the DNS server that handles the AD forest DNS. – Ray Nov 3 '11 at 11:46

You could try setting the clock to your gateway. That will sync the server to your computer and that worked for me.

(late answer to fellow Mac users!)

share|improve this answer
Setting the clock has nothing to do with joining a windows domain. – DavidPostill Oct 13 '14 at 12:22
Yes it does. If your computer is not synced with the windows domain, you will get error node (2000). And it would be imposible to connect/add the domain. or? – vegard Oct 13 '14 at 12:46
Ah, OK ........ – DavidPostill Oct 13 '14 at 12:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .