Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to get an mac mini running snow leopard server to join a windows domain here. The windows domain server is running Windows server 2008.

When I go to "Accounts" in my System Preferences, and lick on "Join", I get this error: "Unable to add server. Node name wasn't found. (2000)"

In my console messages I find this:

10-04-06 11:42:25 AM System Preferences1452 -[ODCAddServerSheetController handleOtherActionError: gotError: Error Domain=com.apple.OpenDirectory Code=2000 UserInfo=0x2004f2f80 "Custom call 82 to Active Directory failed.", Node name wasn't found.

I specified a FQDN for the domain server, so I am totally confused as to why it would list "domain = com.apple...." in that error.

I've tried firing up the Directory Utility and trying to join a domain via the Active Directory option there. Again I fill in the FQDN, and the proper administrator/password acount info. Now I get a different error:

"Invalid Domain

An invalid Domain and Forest combination was specified. You should enter a fully qualified DNS name for the domain and forest (e.g., ads.company.com)."

If anyone has any pointers or suggestions this would be appreciated.

share|improve this question
    
Error Domain=com.apple.OpenDirectory means that is where the error originated, not what domain you typed in. Error and Domain in this context are contiguous. Also, try to bind to AD using the directory utility located in /System/Library/CoreServices/Directory Utility.app. –  C0D3M0NK3Y Sep 3 '11 at 3:37
add comment

1 Answer

The AD domains are discovered by looking at DNS. There is a resource record added for _ldap._tcp.dc._msdcs for each domain you have an AD domain.

Make sure your OS X box can resolve these DNS entries.

share|improve this answer
    
Achieve this by statically setting your primary DNS address in Networking to the address of the DNS server that handles the AD forest DNS. –  Ray Nov 3 '11 at 11:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.