Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I flashed my WRT54G (v3) from a custom firmware to the lastest Linksys one (v4.21.1)

Now the internet/LAN works fine, but the web interface (http://192.168.1.1/) shows broken pages.

I tried to manually navigating to the firmware upgrade page (by entering its URL), but it is broken too and not working.

I tried a 30/30/30 reset twice, but the broken web interface still shows up.

I tried to flash using the tftp2.exe application, which told me that the router didn't respond to the request.

I tried to flash using the Windows commandline TFTP protocol, but I don't know how to supply a password on this prococol. (there is a factory default password ("admin") which I can't remove since the web interface is broken)

Is there any way to recover from this bad flash?

share|improve this question

2 Answers 2

You may want to check out the following link, they offer a number of solutions that might revive your router:

http://www.dd-wrt.com/wiki/index.php/Recover_from_a_Bad_Flash#WRT54G.2FGL.2FGS

If none if these work, I recommend calling Linksys support since it is an official image. One of the methods of the link includes shorting the flash chip. Do take the caution they give you seriously...

share|improve this answer
up vote 1 down vote accepted

After several hours of troubleshooting, I finally found the problem.

Here's where I found the solution: http://www.dd-wrt.com/wiki/index.php/Recover_from_a_Bad_Flash#Recovering_with_TFTP

(thanks BloodPhilia, you were close to the solution)

The article says:

Prepare your PC, firmware file and TFTP software and play with the timing of powering it on and starting the TFTP session just after applying power (or as soon as you start to see ping replies). If you try it a number of times (at least 10) you will probably rescue the router with no fuss!

If you see an 'Invalid Password' prompt from the router the bootloader did not accept the TFTP image and the firmware is refusing the TFTP upload. You can force the bootloader to accept the TFTP upload by holding the reset button while powering up the router. You may also improve success rates by ensuring there is a switch or hub between the PC and the router, maintaining link state when the router power cycles.

Also the tftp2.exe application I used provided a textbox for a password. This needs to be leaved blank. I tried to enter the router password ("admin") which in fact wasn't needed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.