Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have read this knowledgebase article, but would like to know if there's a way to tell exactly which process is causing my Mac not to follow the sleep schedule I have set in System Preferences > Energy Saver. I have narrowed it down to a being a process and will explain why I think so (see below).

I am running OS X (10.6.5) on the new iMac 27" and I am certain it's not the following:

  1. The "Wake for Network Access" checkbox in Energy Saver settings (has never been a previous issue)
  2. Peripherals (has never been a previous issue)
  3. Any active GUI application (all are closed)
  4. Additional USB/FireWire drives (none are connected)
  5. Bluetooth (it's off)
  6. Sharing services (has never been a previous issue)

The symptoms are as follows:

  1. The computer doesn't go to sleep at the predetermined time.
  2. It will wake up some number of hours after being put manually to sleep (but not within the first few seconds/minutes.)

Is there a specific string I should be looking for in Console? I have tried searching for "wake" and "sleep" but can't make total sense of the results.

share|improve this question
1  
Remove all Login Items from your user account in System Preferences » Accounts, log out, and back in. Check all LaunchAgents and LaunchDemons to see if some are third party (probably those not com.apple...), and disable them for launchd. Did you completely replace your previous machine, or do you use both (e.g. same network)? –  Daniel Beck Dec 27 '10 at 16:19
    
@Daniel, please convert your comment to an answer. –  user3463 Dec 27 '10 at 18:02
    
Please follow up on comments and answers for troubleshooting questions such as this. If the problem went away, or you figured it out yourself, please say so. –  Daniel Beck Dec 29 '10 at 20:14
    
Hey Daniel. I'm still sorting it out. I have done what you recommended and it doesn't seem effective either way. Sorry for the delayed feedback. –  pattern86 Dec 30 '10 at 23:54
    
I have also noticed that my iMac will wake up every hour on the minute to update network settings (airport). I am viewing this in the console. Additionally,in viewing console output, I see this string as frequently as every two minutes, to as sparse as every 1.5 or 2 hours. 2010/12/30 19:00:41 kernel AirPort: RSN handshake complete on en1 –  pattern86 Dec 31 '10 at 0:02

2 Answers 2

  • Remove all Login Items from your user account in System Preferences » Accounts, log out, and back in.
  • Check all LaunchAgents and LaunchDemons to see if some are third party (probably those not com.apple...), and disable them for launchd.

If the issue disappears, it's based on some software you're running in the background.

Did you completely replace your previous machine, or do you use both (e.g. same network)?

While I don't see the value in "guessing" answers for troubleshooting issues, I'm posting this as an answer as per @Randolph Potter's request

share|improve this answer
    
I removed all login items and LaunchDaemons and LaunchAgents that were third-party (even though they didn't cause problems before). Still no change. This is not a new machine or a restore. This is just a recently-occurring problem. –  pattern86 Dec 30 '10 at 23:57
up vote 0 down vote accepted

The cause was that iMac was physically located at just the right place (or wrong place) to cause it to switch back and forth between two wireless access points. This apparently was resetting the sleep timer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.