Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Been banging my head on the wall for some time now.

I have a fresh install of Windows 7 - Ultimate ~x86. Some IPs can't resolve properly, it doesn't matter if I try using Firefox, Chrome or IE I end up with a domain not found (server not found, etc.)

I am behind a router, all the other computers aren't affected only this Win 7 machine. It's only certain sites.

e.g., facebook's cdn, google group.

Things I have tried:

  • flushdns
  • ipconfig renew
  • Disable IP v6 on the NIC
  • Double checked that the computer was in the right timezone @ the right time.
  • Reinstall the NIC driver.

Again 90% of the sites will work but not the major one :P help!!!

EDIT: I tried using Google's public dns server @ and as an alternative and it worked fine so it's now down to a DNS problem. What doesn't make sense is that using the same DNS all the others computers on the network can access those sites (a mix of iPhone, HTC Magic, xbox 360, XP and Windows Vista).

share|improve this question
Do any of these domains appear in your hosts file (%windir%\system32\drivers\etc\hosts)? Could be a source of interference. – Jeff Mercado Dec 28 '10 at 4:14
@Jeff M there is nothing in the host file but the standard commented out text. # localhost name resolution is handled within DNS itself. # localhost # ::1 localhost – jfrobishow Dec 28 '10 at 17:20
Change your DNS servers to Open DNS in your tcp/ip – Moab Dec 28 '10 at 18:05
@Moab yes it works using an OpenDNS provider. What I don't understand is why this is the only computer on this network where it will not work using the one provided by my router (and therefore ISP) – jfrobishow Dec 29 '10 at 12:49
usually I am so glad it works, I don't question why, strange problem indeed. Set the DNS in the router to Open DNS servers, see if this cures it. – Moab Dec 29 '10 at 13:54

Make sure DNS service on the machine is running.

Ping and tracert those sites. See what you get back.

share|improve this answer
@alpha1 DNS client is running, I can ping the IP but not by domain so its definitely dns that is not resolving. Ping/tracert on the domain doesn't resolve. – jfrobishow Dec 28 '10 at 17:21
@alpha1 See my edit in the OP. I tried Google's DNS and it worked but the stange thing is that all the other computer using the router's dns (from my ISP) can get to those sites. – jfrobishow Dec 28 '10 at 17:38
Turn off the firewall, and any anti spyware etc and try it then. Something could be blocking the DNS port (It could also be a virus or something of that sort so make sure to turn everything back on) – alpha1 Dec 29 '10 at 2:44
@alpha1 I tried with and without the firewall, no difference. There is no antivirus or antispyware. It's a fresh install of Windows that I did before the holidays so I could rdp into work from my parents. Nothing else ran on it but an rdp session and the occasional visit to facebook (where I initially noticed the problem.) – jfrobishow Dec 29 '10 at 12:51
And you did updates drivers and such? – alpha1 Jan 1 '11 at 7:38

Also check your firewall logs and anti virus logs to doublecheck that they are not blocking these sites e.g. by proxying the requests.

share|improve this answer
There are no installed anti virus at the moment as it's a fresh install. The only firewall was the Windows firewall that is enabled by default. I tried disabling it and it didn't resolve the issue. – jfrobishow Dec 28 '10 at 17:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .