Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was checking my PC settings using AIDA64 (supposed to be the successor for Everest - it basically shows you detailed hardware you currently have). For my ATA hard disk it shows the setting for DMA as "supported, disabled". But when I checked the windows setting I see that it is actually enabled. How can I find out which is correct? And if its disabled what do I do to enable it? Thanks for your help.

Edit: If you right-click on the screenshot - open in new window/save and then open it you can see a much bigger version. Please let me know if you have any problems seeing it.

Here are some screenshots for this:

enter image description here

enter image description here

share|improve this question

I found the following information here. If you go to enable it, you will also be able to check if it is enabled.

-Hope this helps.

  1. Open the explorer (STRG+E)
  2. Right-click on “Computer” and click on “Manage”
  3. Click on “Device Manager”
  4. Uncollapse IDE ATA/ATAPI controllers
  5. Right-click on any label where “Channel” is part of the name – Click on Properties
  6. Go to the Advanced Settings tab, under Device Properties check “Enable DMA”
share|improve this answer
    
If this doesn't work - uninstall the adapter drivers and let Windows reinstall them. Windows disables DMA if it encounters x errors in a row, but these checkboxes remain checked – Sathya Dec 29 '10 at 3:10
    
How do we check the errors encountered? – Mugen Dec 29 '10 at 4:34
    
Thanks for your steps. I had already read these steps and at step 6 noticed that "Enable DMA" is already checked. Hence the confusion. – Mugen Dec 29 '10 at 4:37
    
@Mugen wow, I feel stupid now. I didn't notice that they were your screenshots. Sorry for telling you information that you already knew. I would have to agree with @Sathya on this one then. Uninstall the drivers and reinstall. I don't know if there is a way to see errors unless they were recent enough. You may be able to find the errors in event viewer. I think that the simplest way to get to event viewer is to click "start" button and type event viewer and let Windows 7 find it for you. Also, did you try disabling DMA and re-enabling it? If you need anymore help, please let me know. – David Dec 29 '10 at 13:05
    
Thats okay, it happens to us all. :) Thanks for trying. – Mugen Jan 3 '11 at 17:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .