Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I know this is not a Windows site, so my apologies. I use Ubuntu all day, every day, and have finally convinced my buddy to try it. He is on Windows 7, so we installed this. It seems to be working great, but when he hits C-p ( prev. line ) it is trying to print the page for some reason.

So, 2 questions. Is there a way to make it stop that, and is there a way to just run it from the command line, or without all of the fancy mouse stuff? Essentially as --no-windows?

Thanks!

share|improve this question
2  
This site is OS-agnostic. What gave you the impression that it was otherwise? –  Dennis Williamson Dec 28 '10 at 22:14
    
As evidenced by the thousands of questions tagged windows, @Dennis is correct. –  Shinrai Dec 28 '10 at 22:18

1 Answer 1

up vote 2 down vote accepted

Does Ctrl+C copy and Ctrl+V paste?

If so, it's probably in cua-mode.

Try adding

(cua-mode nil)

to his .emacs file, or disable CUA mode in the Options menu.

Of you could disable just Ctrl+P by adding something like this in .emacs:

(global-set-key "\C-p" 'previous-line)

And if none of that works, try typing this:

M-x describe-key <Ctrl><P>

where M-x means press Alt and x and

means press Ctrl and p.

It will say "It is bound to print-buffer" or "It is bound to ps-print-buffer-with-faces" or similar. Then Google for Windows Emacs print-buffer, or whatever it is bound to.

share|improve this answer
    
I forgot to mention, but CUA is definitely disabled, I'll try adding the set-key line to the pref file. –  Josh Dec 28 '10 at 23:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.