Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to connect to my VMWare (Workstation 7.1.3) machine (Ubuntu Lucid) via SSH. I've read through some other posts, but I can't figure this out. I ran ifconfig, and got a inet addr: and Bcast and Mask: which appear to be IP addresses. If I try to connect via Putty SSH to any of those addresses, it doesn't work. I also tried connecting to my IP address (from whatismyip.com).

Note: This is all taking place on the same desktop computer.

share|improve this question

migrated from serverfault.com Dec 28 '10 at 22:29

This question came from our site for professional system and network administrators.

Can you ping the 'inet addr:' of your VM from the desktop computer ? –  Iain Dec 28 '10 at 20:28
It is important that the Network Adapter in the VM settings be changed to the Bridged mode. –  amphibient Aug 19 '13 at 19:54

5 Answers 5

up vote 13 down vote accepted

Is the package openssh-server installed on your Ubuntu VM? You'll need that package if you want to connect to it by SSH.

You can make sure by opening a terminal (through VMWare's console, I guess) on Ubuntu and running:

sudo apt-get install openssh-server
share|improve this answer

Are you using Bridged Mode? NAT mode is the default, and won't let you connect to your VM guest.

If you make some other selection in the New Virtual Machine Wizard and later decide you want to use bridged networking, you can make that change in the Virtual Machine Control Panel (Edit > Virtual Machine Settings).

See VMWare Bridged Networking and Changing the Networking Configuration for details.

share|improve this answer

How to do it? Here are the complete steps. Just follow these steps:

  1. In the terminal use command: sudo apt-get install openssh-server

  2. Switch to bridged networking mode, make that change in the Virtual Machine Control Panel (Edit > Virtual Machine Settings)

  3. reboot the VM

  4. Run "ifconfig" command in terminal & get "inet addr" of "eth0"

That's all ! Now use this IP to connect via ssh (I use Putty in my Windows 8)

share|improve this answer

NAT mode is the default, and won't let you connect to your VM guest.

Even in NAT mode, this used to work until VMPlayer ~ 2.5 (you just had to use the private IP; 192.168.X.Y). Don't know why this isn't working anymore (this was so useful).

share|improve this answer

Don't use Bridged Adapter for Ubuntu, I tryed on 13.10 and it doesn't work. Use NAT instead, it worked fine for me.

share|improve this answer
If possible, you can really improve the quality of your answer by adding references, code examples, how-tos, case examples and including specific information about what you did! –  G Koe Mar 11 at 18:03
"We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed." –  damryfbfnetsi Mar 11 at 18:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.