Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to connect to my VMWare (Workstation 7.1.3) machine (Ubuntu Lucid) via SSH. I've read through some other posts, but I can't figure this out. I ran ifconfig, and got a inet addr: and Bcast and Mask: which appear to be IP addresses. If I try to connect via Putty SSH to any of those addresses, it doesn't work. I also tried connecting to my IP address (from whatismyip.com).

Note: This is all taking place on the same desktop computer.

share|improve this question

migrated from serverfault.com Dec 28 '10 at 22:29

This question came from our site for system and network administrators.

    
Can you ping the 'inet addr:' of your VM from the desktop computer ? – Iain Dec 28 '10 at 20:28
    
It is important that the Network Adapter in the VM settings be changed to the Bridged mode. – amphibient Aug 19 '13 at 19:54
up vote 20 down vote accepted

Is the package openssh-server installed on your Ubuntu VM? You'll need that package if you want to connect to it by SSH.

You can make sure by opening a terminal (through VMWare's console, I guess) on Ubuntu and running:

sudo apt-get install openssh-server
share|improve this answer

How to do it? Here are the complete steps. Just follow these steps:

  1. In the terminal use command: sudo apt-get install openssh-server

  2. Switch to bridged networking mode, make that change in the Virtual Machine Control Panel (Edit > Virtual Machine Settings)

  3. reboot the VM

  4. Run "ifconfig" command in terminal & get "inet addr" of "eth0"

That's all ! Now use this IP to connect via ssh (I use Putty in my Windows 8)

share|improve this answer

If the network is configured properly - either with port-forwarding or as "bridged" and SSH is still not working (from the question text that seems to be the case), then it's either that ssh is not installed or not running. For example, ssh is not running by default on Kali although it's already installed. You'll have to run it yourself.

To start the ssh service:

service ssh start
share|improve this answer
1  
This is as valid answer as the approved one. If the network is configured properly - either with port-forwarding or as "bridged" and SSH is still not working (from the question text that seems to be the case). Than, it's either that ssh is not installed or not running. For example, ssh is not running by default on Kali although it's already installed. You'll have to run it yourself. – guya Apr 5 '15 at 23:32

check the SSH is allow or not in firewall setting, if you use Linux read hate. click on system - Administration - security level and firewall - click on firewall option tab and enable it apply and save . here you can allow telnet and https as well.. Thanks

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.