Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to connect to my VMWare (Workstation 7.1.3) machine (Ubuntu Lucid) via SSH. I've read through some other posts, but I can't figure this out. I ran ifconfig, and got a inet addr: and Bcast and Mask: which appear to be IP addresses. If I try to connect via Putty SSH to any of those addresses, it doesn't work. I also tried connecting to my IP address (from whatismyip.com).

Note: This is all taking place on the same desktop computer.

share|improve this question

migrated from serverfault.com Dec 28 '10 at 22:29

This question came from our site for system and network administrators.

    
Can you ping the 'inet addr:' of your VM from the desktop computer ? –  Iain Dec 28 '10 at 20:28
    
It is important that the Network Adapter in the VM settings be changed to the Bridged mode. –  amphibient Aug 19 '13 at 19:54

4 Answers 4

up vote 15 down vote accepted

Is the package openssh-server installed on your Ubuntu VM? You'll need that package if you want to connect to it by SSH.

You can make sure by opening a terminal (through VMWare's console, I guess) on Ubuntu and running:

sudo apt-get install openssh-server
share|improve this answer

How to do it? Here are the complete steps. Just follow these steps:

  1. In the terminal use command: sudo apt-get install openssh-server

  2. Switch to bridged networking mode, make that change in the Virtual Machine Control Panel (Edit > Virtual Machine Settings)

  3. reboot the VM

  4. Run "ifconfig" command in terminal & get "inet addr" of "eth0"

That's all ! Now use this IP to connect via ssh (I use Putty in my Windows 8)

share|improve this answer

Don't use Bridged Adapter for Ubuntu, I tryed on 13.10 and it doesn't work. Use NAT instead, it worked fine for me.

share|improve this answer
2  
If possible, you can really improve the quality of your answer by adding references, code examples, how-tos, case examples and including specific information about what you did! –  G Koe Mar 11 '14 at 18:03
1  
"We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed." –  gparyani Mar 11 '14 at 18:32
    
Er.... nothing more I can explain. –  Keanu73 Oct 27 '14 at 14:19

If the network is configured properly - either with port-forwarding or as "bridged" and SSH is still not working (from the question text that seems to be the case), then it's either that ssh is not installed or not running. For example, ssh is not running by default on Kali although it's already installed. You'll have to run it yourself.

To start the ssh service:

service ssh start
share|improve this answer
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. –  smc Apr 5 at 21:10
    
This is as valid answer as the approved one. If the network is configured properly - either with port-forwarding or as "bridged" and SSH is still not working (from the question text that seems to be the case). Than, it's either that ssh is not installed or not running. For example, ssh is not running by default on Kali although it's already installed. You'll have to run it yourself. –  guya Apr 5 at 23:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.