Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to update my Mac OS X 10.6.3 and want to use the manual package update (not Software Update) and I am having this problem for two days now. First I downloaded Mac OS X 10.6.5 Combo update and on the first opening it popped up a message saying "Unable to mount: disk image not recognized". I thought that somehow the image became corrupt during the download, so I downloaded it again. Same result. And I downloaded again. And again... No use, it still states that the .dmg is not recognized.

Then I tried to update my system from 10.6.3 to 10.6.4 using the same method (package installer). It worked. And of course I downloaded the 10.6.5 update (not the combo package, but the 10.6.4 > 10.6.5 update package)... guess what. Not recognized.

I don't understand how is this possible. Did anyone has the same problem? Please don't advice me to use software update, as I need to do that on multiple Macs

Thanks in advance.

share|improve this question
up vote 1 down vote accepted

Have you checked the disk image file size and SHA1 has (listed on the Apple download page to make sure it's intact? Here's what I get on my copy (my hash matches what Apple gives):

$ wc -c MacOSXUpdCombo10.6.5.dmg 
 1024680576 MacOSXUpdCombo10.6.5.dmg
$ openssl sha1 MacOSXUpdCombo10.6.5.dmg 
SHA1(MacOSXUpdCombo10.6.5.dmg)= add336a1af1c3914887d2217fbbc98b18e6fb57c
share|improve this answer

Did this behaviour repeat itself on multiple Macs or just the one? If it's just the one, I'd run the Software Update on that one only.

You could also have a file system error. I'd recommend running a drive repair under the Disk Utility to make sure everything's okay.

share|improve this answer
I did everything these two days: Disk Utility (Repair disk, Repair disk permissions), booting under safe-mode etc... The behaviour is the same on all Macs. I did my homework too (searching forums, reading discussions). All other .dmgs are opening, except for this particular one 10.6.5 update – Lawliet Dec 28 '10 at 23:19
Then the download is corrupt. Check what @Gordon has written to confirm that it's complete. – user3463 Dec 29 '10 at 23:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.