Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

OpenDNS hijacks keywords that you type into the address bar and redirects those searches to their own search interfaces that pulls in Google results and their own ads.

This is really the only thing that I do not like about OpenDNS, is there a way to disable this behavior?

Note: if I disable the OpenDNS proxy it also seems to disable content filtering which is one of the main reasons I have OpenDNS enabled on my network. So that doesn't seem to be a good solution.

share|improve this question
1  
I switched to running my own internal DNS server on my LAN because of the hijackery. –  jtimberman Aug 14 '09 at 7:14

3 Answers 3

I think this SF answer for Tracking all DNS calls within a network would help you.

Login to OpenDNS, click through

  • Dashboard,
    • Settings,
      • Advanced Settings, and,
        • Uncheck Enable typo correction
        • Apply
      • Content filtering (these controls are in a different path)

Moreover, like I added in the comment, I have a feeling the Serverfault answer also fits here (OpenDNS is probably not the problem).

share|improve this answer
    
This will disable OpenDNS content filtering, though, which the original poster wanted to avoid. –  arathorn Aug 14 '09 at 14:26
    
@arathorn, content filtering is differently handled, this is just typo correction. Moreover, I feel that this is more of a browser effect rather than OpenDNS. Adding the content filtering path in the answer for reference. –  nik Aug 14 '09 at 17:22
    
@nik: That's what I would think also, but try it for yourself (I just verified it) -- disabling the typo correction will turn off the content filtering features also. –  arathorn Aug 14 '09 at 17:26
    
@nik: Here's what you'll see on the Content Filtering page after disabling Typo Correction: www-files.opendns.com/dashboard/img/placeholder_filtering.gif –  arathorn Aug 14 '09 at 17:31
    
@arathorn, Ok, that was news to me. Never tried it myself. But, learned something now. However, do you think that the OP needs to look at browser settings rather than OpenDNS? I looked some more and came up with this link labnol.org/software/browsers/…,,, Don't know if its validated. –  nik Aug 14 '09 at 17:53

If you add

127.0.0.2   guide.opendns.com

To your hosts file (usually in C:\Windows\System32\drivers\etc in windows)

Then when it tries to redirect you to the hijacking page at guide.opendns.com it will try to go to 127.0.0.2 which presumably doesn't exist. And your browser should give you the normal response for not finding a domain (I tried it on my machine and it works okay).

share|improve this answer
1  
This almost works. It results in an error page when you perform an address bar search instead of taking you to your default search engine. –  spoon16 Aug 16 '09 at 17:57
up vote 0 down vote accepted

This Firefox addon provides a good solution (for Firefox anyway). In the options for the addon you can choose Bing, Google, Yahoo, or Google I'm Feeling Lucky.

Addon Link: Feeling Lucky Fixer

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.