Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed LibUSB, a software that modifies your USB driver so that programs can access it easily. I didn't know that in Windows 7 you have to run it in compatibility mode for Windows XP, so now my Windows 7 can't access any USB port (including keyboard and mouse). Now I can't access my computer at all, and I don't have any PS2 connection in my computer. I tried to run it in Safe Mode but it didn't change anything. I tried to run a system restore from before the installation of LibUSB, but all the restore points give me an error: "The instruction at 0x73888f18 referenced memory at 0x00000004. The memory could not be read." I also tried to run Hiren's Boot CD and remove all the files associated with LibUSB, but that didn't change anything. So how can I remove LibUSB and access my computer again without formatting my hard drive? (I have important things on it)

share|improve this question
Restart in safe mode, that shouldn't load any third-party drivers. – Bobby Dec 29 '10 at 20:15
Oh, forgot to say that I already tried that and that didn't change anything. I've added that now. – Cokegod Dec 29 '10 at 20:23
Are you trying to use System Restore from the Startup Repair menu, before you get into Windows? – Kez Dec 29 '10 at 20:23
No, I tried to run System Restore from the Windows 7 installation disk. – Cokegod Dec 29 '10 at 20:27
Try reinstalling your chipset driver, or use the latest chipset driver available. – Moab Dec 29 '10 at 23:52

There are many reports of issues with libusb and windows 7. I have also had this problem but cannot remember exactly how to resolve the issue. You should be able to resolve the issue without reinstalling or formatting your disk.

You need to uninstall the driver if possible by using F8 on startup to enter safe mode, then running the uninstall program for libusb.

The solutions outlined in the following link may help:

share|improve this answer
did the same exact thing the first time I tried to use libusb. Booting into safe mode then uninstalling the driver fixed my issue. – g19fanatic Feb 2 '11 at 18:24

I just got something to work for me right now, and I know this is fairly late in time but for future people who get their USB ports ganked here's something that worked for me

  1. Go to Driver Manager
  2. Scroll all the way down and see for Xbox 360 Peripherals (Or something of that matter)
  3. Drop it down and right click
  4. Uninstall the device and driver and click the box in it that says "Uninstall Driver and Software"

This should restore access for you if you installed MotionJoy or Libusb. Also if you see anything under LibUSB in the Device manager, uninstall that as well.

share|improve this answer

You could run a Repair Install from the Win7 disk.

share|improve this answer
What exactly does it do? I don't want to accidentally remove something I need... – Cokegod Dec 29 '10 at 20:56
Repair Install replaces Windows files while leaving applications and data untouched. – CarlF Dec 30 '10 at 13:45

Reinstall it in compatibility mode, then use Revo uninstaller to remove it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.