Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a very odd problem that I can't resolve. I am connected to the internet, but my browsing doesn't work. I don't mean a web browser - I mean browsing. Firefox, Chrome, Curl all fail to successfully connect to an HTTP address.

However existing connections, e.g. to mail in Outlook (Exchange Server and also IMAP server) continue to work.

**Update: Existing RDP connection (port 3389, Windows Remote Desktop) continues to work as well. New FTP connection does not (on port 5050, running FTPS). Skype login also fails (likely this runs over port 80 as well.

Also, the internet is on, I can confirm both from my machine (other ports / connections) as well as from any other computer connected to the same network.

Additionally, it appears to be HTTP, not simple a port issue as HTTP over port 8443 (Tortoise SVN if you must know - running over HTTP not over SVN) also fails.

I am using Windows Vista SP2 (build 6002). It seems to "creep up" in that after running the computer for a few hours it will fail. (No found way to systematically reproduce the problem.) Additionally, it seems to be more prone on days where the internet connection is flaky already (not sure why the internet is flaky, just is, lot's of failed browsing requests and have to retry/reload often).

What I have tried (when the problem arises) - none have yielded any resolution:

  • Resetting the network connection (dis-connect, re-connect)
  • Disable/re-enable the network adapter
  • Double-checked the ip settings
  • Double-checked the HOSTS file. Note: DNS continues to work (both new and cached responses to DNS queries). (Thanks for the suggestion Daniel and antenore.)
  • Checked the routing tables (ip4 only as ipv6 is beyond my understanding)
  • resetting all involved hardware (routers and modems)
  • Close and reopen browsers
  • Changed which hardware port I was connected to on on the router
  • Checked for any incorrect proxy configuration. (ht/ sdanelson)
  • Looked for malware interference:
    • Run HijackThis
    • Looked for suspicious processes using SysInternals procexp.
    • Looked for explorer hijacks, lsa provider interference, winsock provider interference using SysInternals Autoruns.
    • Run a complete anti-virus scan.
  • Reviewed the output of a netstat -onab to see if there were stuck ports open or unusual processes running somewhere

The only thing that works is to do a full reboot. That works 100% of the time to restore browsing.

What else can I try to nail down the problem?

share|improve this question
It's not just a DNS issue and Exchange, IMAP, and SVN happen to be configured for IP addresses? – Daniel Beck Dec 29 '10 at 22:08
@Daniel - nope, nslookup tests continue to work. And SVN failed, not succeeded. – jeffreypriebe Dec 29 '10 at 22:20
Maybe there's something interesting happening in Wireshark, e.g. does your machine send requests, are they well-formed, do you get answers? – Daniel Beck Dec 29 '10 at 22:26
That's a worthwhile suggestion. I don't get answers, but I haven't checked to see if something is corrupting the request somewhere in the stack. – jeffreypriebe Dec 29 '10 at 22:43
You're not running Zone Alarm, are you? I had a very similar issue a while back and that was the culprit. – Al E. Dec 30 '10 at 2:18

I doubt this is it but check your proxy settings. It has the potential to impact all of the browsers you mentioned, but leave the other software unaffected. I have seen instances where malware plays with your proxy settings.

share|improve this answer
Checked and no the issue. Good idea though. – jeffreypriebe Dec 30 '10 at 14:05

Check C:\windows\system32\drivers\etc\hosts (not sure about the path, I'm on Linux) and remove any entries you don't need (normally all), if it has been modified use another anti malware software (spybot for example).

Seems to me a DNS issue, but as it happens randomly, I really suspect a malware or a virus.

I advice to test spybot and claim antivirus

share|improve this answer
Good point, yes I've checked that. I'll update the description. Also, DNS still works (both cached queries and new queries). I'd upvote your good idea, but I don't have the rep. I didn't try clam AV specifically, but I did do an AV scan and several other anti-malware checks. – jeffreypriebe Dec 29 '10 at 22:19
Also, that path is almost spot on: C:\Windows\system32\drivers\etc\hosts (filename has an "s") Note for others: You need to run notepad (or whatever program) as an administrator if you are trying to edit it. – jeffreypriebe Dec 29 '10 at 22:24
did you try as well the ipconfig /flushdns and ipconfig /registerdns? – tmow Dec 29 '10 at 22:28
Haven't tried that. Will, but I am not optimistic: DNS is working. – jeffreypriebe Dec 29 '10 at 22:42
I would try from the command line to do a telnet to one of the domain you are trying on port 80, if it doesn't work I'm quite sure it's your ISP that is blocking by mistake the port 80. Did you open several connections with some scripts, or did you start a public web server using your ISP network? Try for example start->run->cmd ---> telnet 80 – tmow Dec 29 '10 at 22:54

Having read all the answers i don't see anywhere the word firewall, have you checked vista's configuration? i remember Norton Antivirus if removed improperly would stay blocking stuff, maybe your current or a previous antivirus is causing the problem, or another firewall software you had installed, some machines come with pre-installed crapware that does firewall stuff.

share|improve this answer
I would have put this as an answer if Guillermo hadn't. Disable your firewall and see if it fixes your problem (Windows and third-party). Also, I have to say the same as Daniel Beck up there too, Wireshark is a great tool to see what traffic is going where. – blsub6 Dec 31 '10 at 0:49
I will definitely check all firewalls. Haven't used Wireshark - thanks for the +1, I'll check it out. – jeffreypriebe Dec 31 '10 at 15:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .