Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We are serving files with the .xlsx (excel 2007/2010) extension. IE, Chrome, Safari all download the file and open excel just fine.

For some reason Firefox is appending .xls to the extension. I found this: https://support.mozilla.com/bs/questions/758363

However, the instructions weren't very specific and completely unclear to me.

How can I tell Firefox not to screw with the file extension?

I'm using 3.6.13 on Windows 7.

Thanks,

share|improve this question
    
Resetting automatic actions, as indicated in the link you provided, is per client, so you'd have to change the setting on each install of Firefox. – user3463 Dec 30 '10 at 2:14
    
@Randolph: Per client is okay as I'm just trying to fix two machines. I went through the instructions but that didn't work. Either the instructions are bad or I completely misunderstood what to do. – NotMe Dec 30 '10 at 15:20
    
it's entirely possible that your MIME types are messed up, especially with Firefox. I really don't know what to suggest if that page didn't help (though to be fair, I only read through it and didn't actually try anything). – user3463 Dec 30 '10 at 20:51
up vote 1 down vote accepted

Instead of changing Firefox, I found that the site in question was sending the wrong mime type for office 2007/2010 documents. Fortunately, they were kind enough to fix it.

I think Firefox ought to leave the extension alone, but I doubt that's going to change anytime soon given the severe lack of attention to the many bugs filed about it.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .