Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently started having the common, as I realized, problem of not being able to rename folders in Windows 7 (32 bit).

I don't understand why it happened after almost a year of ideal use of Windows 7.

I haven't removed the libraries nor can I think of anything else that could potentially cause this, at least as far as I know.

The only thing I did recently was to change my anti-virus program from the freeware version of Avira to the freeware anti-virus Microsoft Security Essentials.

Any idea on what the problem is and how to fix this?

share|improve this question
    
do you get any error while rename? – Ankur Dholakiya Dec 30 '10 at 5:29
    
"Can't rename folder"? Why? What happens if you right-click the folder, choose "Rename", type a new name, then press Enter? – Dour High Arch Dec 30 '10 at 5:32

Seems a Microsoft Update (KB980408) caused this issue on some systems.

“Deleting the following registry keys, and rebooting, has solved the problem for me:”

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{2112AB0A-C86A-4ffe-A368-0DE96E47012E}]
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{491E922F-5643-4af4-A7EB-4E7A138D8174}]
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{7b0db17d-9cd2-4a93-9733-46cc89022e7c}]
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{A302545D-DEFF-464b-ABE8-61C8648D939B}]
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderDescriptions\{A990AE9F-A03B-4e80-94BC-9912D7504104}]

Source of Information

share|improve this answer
    
+1: Fixed it for me - had been suffering this for weeks! :) – Umber Ferrule Jul 7 '11 at 22:45
    
Dude I would give you a nobel prize for this one! This should be marked as correct answer ! Only solution i found that actually works! Thanx – Haris Apr 2 '13 at 13:35

You can try renaming using Command Prompt.

share|improve this answer
1  
I get the error: – Tasos Dec 30 '10 at 6:03
1  
Item not found - but when i click try again it works – Tasos Dec 30 '10 at 6:04

I recommend using File Unlocker to do it. I recommend version 1.8.7 (which had no spyware/toolbar payload with it) but version 1.9.1 might be safe to use.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .