Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using VirtualBox on a Ubuntu 10.04 64bit host. I would like to install a Fedora 64bit guest.

When I try to run the 64bit live cd, it says "Automatic boot in 10 seconds..." after which I get a blue background with no menu options. I am familiar with Ubuntu but not Fedora.

I have been able to install a Fedora 32 bit system just fine.

Any suggestions? I am trying to run an rpm that won't run in Ubuntu even using alien.

update I tried to install from the full distribution (non-live) DVD image, and the installation stopped with the error

this kernel requires an x86-64 CPU, but only detected an i686 CPU

However, the results of uname -a indicate that my host is x86-64:

user@desktop:~$ uname -a Linux user-desktop 2.6.32-26-generic #48-Ubuntu SMP Wed Nov 24 10:14:11 UTC 2010 x86_64 GNU/Linux

Have I configured VirtualBox incorrectly?

alt text.

share|improve this question

2 Answers 2

Can you please provide the exact model of your Processor?

because some processors don't give you access to 64 bit Modes in virtual machines, even though its supported on the host ...

Also, please make sure that you have the Intel VT-X mode (assuming its an intel CPU) enabled in the BIOS settings on the host ...

Awaiting your update :)

share|improve this answer
    
its most likely the lack of VT-X that's causing the problem IMO –  Journeyman Geek Apr 10 '11 at 9:50
    
my two processors are Intel(R) Core(TM)2 Duo CPU E8500 @ 3.16 GHz –  David Mar 21 '12 at 22:08
    
@JourneymanGeek based on the screenshot, it appears that VT-X is enabled –  David Mar 21 '12 at 22:10
    
@David you're still having this error? as per this link: ark.intel.com/products/33911/… your CPU supports 64 bit mode along with VT-x .. check is you have the extensions and the support enabled in the virtual machine options, that's the only culprit that remains for this error to occur –  msalem Apr 1 '12 at 9:56
    
I would have to try this again, but I don't think it is worth trying to reproduce the error at this point, almost 1.5 years later. –  David Apr 1 '12 at 20:17

double check md5 or sha hashes of downloaded ISO/CD with the originals

share|improve this answer
    
I don't quite understand what you mean... –  David Dec 30 '10 at 18:50
    
sometimes .iso file or CD is corrupted (during download/ burning). The place you downloaded Fedora should be a file with checksums. You can calculate the checksum for your downloaded .iso and compare it with that sum on the site (even better if you compare with checksum from original Fedora site). The same is for CD (if you install from CD). If the sums are equal - file is transmitted correctly, if not - download again –  jet Dec 31 '10 at 13:06
    
.. okay, I'll try to download the torrent from torrent.fedoraproject.org since the Transmission will do the checksum for me. will let you know how this goes –  David Jan 3 '11 at 21:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.