Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Ubuntu 10.10 on my laptop.

I was develping websites without any problem so far.

Then suddenly I am not able to access any website in localhost.

Even http://localhost/phpinfo.php does not show.

I reinstalled apache but it is the same result.

I am able to access localhost/phpmyadmin.

Could anyone tell me how to fix this problem?

Thanks in advance.

share|improve this question

migrated from serverfault.com Dec 30 '10 at 22:05

This question came from our site for system and network administrators.

    
What happens when you substitute 127.0.0.1 for localhost ? – Iain Dec 30 '10 at 21:47

I added the following to /etc/apache2/conf.d/fqdn

 ServerName localhost

And it works now.

:-)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .