Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I thought it would be cool to use Mozilla's Prism to create a webapp for min.us, but drag and drop is disallowed because the site doesn't see the program as Firefox, Chrome or Safari, those of which are apparently the only browsers allowed to do drag and drop for fear that something will be horribly broken.

I'm pretty sure Prism runs on the same engine as Firefox, yet I wouldn't doubt it if Prism is running on an older version since it's kind of a forgotten beta.

Anyways, like the title says, I want to be able to make Prism webapps appear as Firefox to websites, so awesome features can be unlocked.

Also, if it can only be done with Fluid, then I answers regarding that will be fine. I'm not sure what engine it's running though.

share|improve this question
    
Fluid uses WebKit, which is the same rendering library used by Chrome and Safari, so it should work fine. I'm assuming you're on a Mac? –  Sasha Chedygov Dec 31 '10 at 7:44
    
I am on a Mac. Also, I found out it's called user agent spoofing. I'm still looking for an answer myself. –  Alex Aaron Goven Dec 31 '10 at 7:52
add comment

1 Answer

up vote 2 down vote accepted

Prism runs on the Gecko rendering engine, just like Firefox.

You can change the user agent Prism sends by modifying prefs.js directly. First, find your prefs.js (the internal Prism settings file). If you're running Windows, this should be in AppData in your user folder (something like C:\Users\<yourname>\AppData\Roaming\<nameofPrismapp>\Profiles\prefs.js), on OS X it should be in Application Support (something like /Home/<yourname>/Library/Application Support/<nameofPrismapp>/Profiles/prefs.js).

Now, in that file, check for a line that looks like this:

user_pref("general.useragent.override", "");

If there isn't one there, add it, and set to the user agent that you want Prism to send. Try something like this:

user_pref("general.useragent.override", "Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9 ( .NET CLR 3.5.30729; .NET CLR 4.0.20506)");

Now you seem to be running Firefox 3.6 on Windows Vista.

share|improve this answer
1  
You forgot [ProfileName] (e.g. 5kfy43gw.default) in the path. –  Daniel Beck Dec 31 '10 at 11:22
    
What's the path to the file in Ubuntu Linux? –  Alex Aaron Goven Jan 1 '11 at 4:44
1  
on Linux you should find it in ~/.prism/<profileName>/prefs.js. As Daniel caught, you should also add the profile to the paths above. –  jcrawfordor Jan 2 '11 at 7:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.