Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to set up Windows in Virtual Box, so I don't need to reboot in the rare occasion that I actually need it.

The problem is, Virtual Box doesn't preform any errors when I insert the 32bit installation CD but when I try to use the 64bit installation;

alt text

What!? I am already using the installation disc!

I've checked my BIOS to see if I have SVM (AMD's version of VT) disabled and all I see is "Enabled"

  • I have a K9N6PGM2-V2 motherboard
  • A Triple Core AMD Athlon II
  • A Nvdia NForce 430 integrated graphics card
  • 4GB of RAM
  • An 80GB IDE
  • And a 1TB SATA

I don't think the last three specifications matter but just in case XP

I am pretty sure the CD isn't broken ( I am going to make sure in just a moment ), what could be the cause to this problem?

Edit: The 64bit installation CD is not broken, but I found out when trying to install from the 32bit version that it's trying to upgrade, not preform a fresh install - Odd.

share|improve this question

migrated from askubuntu.com Dec 31 '10 at 16:00

This question came from our site for Ubuntu users and developers.

1  
Are you using 32 or 64 bit Ubuntu?. Have you checked Activate Vt-x/AMD-V in VirtualBox configuration (Systema->Acceleration). – Javier Rivera Dec 31 '10 at 13:07
    
What's wrong about using 32-bit Windows XP in VBox? – Takkat Dec 31 '10 at 13:28
    
Please improve your question title and description, your problem root is the Windows 7 installer not virtualbox. – João Pinto Dec 31 '10 at 13:48
    
I suggest you download and install the new VirtualBox 4 and see if that makes any difference – 8128 Dec 31 '10 at 14:54

I have found someone which had the same problem and resolved it by enabling the IO APIC in the VM system settings: http://www.linuxquestions.org/questions/linux-software-2/virtualbox-2-1-on-fedora-64-bit-wont-install-windows-7-beta-64-bit-696358/

share|improve this answer
1  
Thanks, I think you have a typo though because enabling it worked, not disabling it. – MetaDark Dec 31 '10 at 16:06

Please make sure your Ubuntu installation is 64 bit, too. You can still run 32bit VMs, then. Running 64bit VMs under a 32 bit host system doesn't work, thorugh.

share|improve this answer
1  
Uh... yes it does. – Nathan Osman Dec 31 '10 at 17:04
    
You can run a 64 bit VM on a 32 bit host IF the processor supports VT and x64 instructions. – nhinkle Dec 31 '10 at 18:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .