Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently purchased this enclosure:

and this HDD:

Now, I let my brother in law use the enclosure with his 160GB disk to back some stuff up. He then gave me that disk in my enclosure and I backed up my computer and my fiances computer. So...obviously, i had no problem mounting that disk. I plan on keeping this disk as my "natural disaster backup" (in case my apartment building burns down, i still have that disk with my stuff backed up).

I want to use the 1.5T disk as my regular/more frequent backup device, but it doesn't seem to be mounting to my F-13 machine.

I searched through this forum and found someone advising to run the following:

# mount -t vfat /dev/sda1 /mnt

this is the output i get when I run that:

mount: /dev/sda1 already mounted or /mnt busy
mount: according to mtab, /dev/sda1 is mounted on /boot

Thing is, shouldn't this disk automatically mount just like the LAST disk in the same enclosure with the same USB cable and power supply? Any help would be greatly appreciated. THANKS!

UPDATE: [root@Moonface ~]# cat /proc/partitions major minor #blocks name

   8        0  156290904 sda  
   8        1     512000 sda1  
   8        2  155777024 sda2  
 253        0   52428800 dm-0  
 253        1    4653056 dm-1  
 253        2   98664448 dm-2  
   8       16 1465138584 sdb  
share|improve this question
can you give us the output from: cat /proc/partitions – jet Dec 31 '10 at 17:25
please see my edit. – Ramy Dec 31 '10 at 22:44
up vote 1 down vote accepted

Disks are often sold without a partition table and without a filesystem. Perhaps you want to install gparted or kde-partitionmanager and use it to format the disk. You can also use cfdisk (or fdisk) and mkfs.ntfs manually, but I'd advise against it if you're not familiar with command line utilities very much.

You need to create a partition (or partitions) on the external drive and then format them using mkfs. If you're going to share the disk with Windows, the only choice is to format them with NTFS, otherwise ext3 or ext4 are probably a great choice.

The following can be useful to map users between your Windows and Linux boxes. This is for an internal drive, but I found an external one easier to use if you do it.

The following is the hard way to do it:

  1. Find the path to the device file of the disk (finding it in /dev/disk/by-id would be easiest, because it has the model and serial number as part of the filename). Let's assume that the device is /dev/disk/by-id/usb-STXXXXXXXX_YYYYYYYY
  2. Run cfdisk /dev/disk/by-id/usb-STXXXXXXXX_YYYYYYYY. You will see an empty partition table with only free space in it.
  3. Press n, it defaults to the maximum possible size, so just press enter.
  4. If you're going to share with Windows, press t to change the type and then enter 07 (which is NTFS), otherwise don't touch the type.
  5. Press w to save it, and then q to quit. The disk will be automatically re-read. If it isn't, run partprobe.
  6. a) If you're not sharing with Windows: Run mkfs.ext3 /dev/disk/by-id/usb-STXXXXXXXX_YYYYYYYY-part1

    b) If you're sharing with Windows: Run mkfs.ntfs /dev/disk/by-id/usb-STXXXXXXXX_YYYYYYYY-part1


  7. Remove the disk and then insert it back, it should be recognized by your favourite auto-mount utility.

share|improve this answer
so far so good. I'll give you full credit once it completes. I've got a Terabyte and a half. Could take hours. – Ramy Dec 31 '10 at 23:10
maybe i should ask this: if I do step 6b, will I be able to access the drive from my fedora box? I ran through your instructions and can now access the disk from my fiance's windows machine, but I can't find it anywhere from my fedora box.... – Ramy Jan 3 '11 at 1:34
All distros I've tried are able to access disks formatted as described with no problem. I haven't tried Fedora, but a quick search for "ntfs-3g fedora" would indicate that this should work at least since Fedora 7. Make sure you have ntfs-3g installed. – TestUser16418 Jan 4 '11 at 0:28

/dev/sda is most likely your internal hard drive. Either monitor the system log for what the actual device node is, or use one of the entries in one of the /dev/disk/by-* directories instead.

share|improve this answer
what do you mean by "or use one of the entries in one of the /dev/disk/by-* directories instead."? – Ramy Dec 31 '10 at 16:52
In place of where you have /dev/sda1 in your mount command. – Ignacio Vazquez-Abrams Dec 31 '10 at 16:56

as I see sdb is your disk so try:

# mount  /dev/sdb /mnt

if the disk is not formated:

# mkfs.ntfs /dev/sdb 

if you give us:

# fdisk -l /dev/sdb

we can tell you if there is a partition/partition table created there

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .