Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.


i downloaded xampp-linux-1.7.3a.tar.gz and installed it manually, not with aptitude. That was a mistake as proved later, due to some configurational issues i decided to remove it and install it via aptitude install apache2. Now the previous lampp conflicts with the new apache2, i get this error message.

  • Starting web server apache2
    apache2: Could not reliably determine the server's fully qualified domain name, using for ServerName (98)Address already in use: make_sock: could not bind to address no listening sockets available, shutting down

how can delete the existing lampp files entirely or how can i configure apache2 to work as intended ?

any help will be appreciated

share|improve this question
looks like you have more than one port 80 instance running – hbdgaf Dec 31 '10 at 18:40

2 Answers 2

All files for xampp are in one central location, /opt/lampp.

Simply run:

/opt/lampp/lampp stop

to stop the Apache, SQL and PHP services, then:

rm -rf /opt/lampp

to remove the content.

You can then start up your apache2 installation via apache2ctl start. You'll want to modify the ServerName directive in httpd.conf to get rid of the annoying hostname error as well.

share|improve this answer

If you have skype running then that could stop port 80 from running. Go to to your skype preferences and make sure that it doesn't use port 80 from the advanced section in the settings.

Also you can try and change the port that apache uses to avoid any conflicts?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.