Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday I had a sudden problem with my Ethernet connection to my router. My computer is a Pentium 4 with Windows XP SP3 running on it and it was working fine earlier in the day, but yesterday night was the start of the problem.

My computer is unable to ping to the router and to any other website and unable to get an Internet connection. As beside it was connected to a hub, I directly connected it to the router directly and the same problem occurred, being unable to ping to the router (and connecting to it) and still no Internet access. I directly connected to the modem and the problem still persisted. For each connection, I connected it to my computer and my laptop and my laptop was able to connect, while my desktop computer was unable. I wondered if it was an OS issue and ran a live Ubuntu CD to see if Ubuntu was able to connect to the Internet, but the issue persisted and I was unable to get Internet access.

I then set my router's lease time to one hour and waited. After one hour, the lease for my computer was removed and I hoped this worked, but it didn't work, but something strange is acting up. My desktop computer is still unable to ping to the router or connect to the Internet, but for some reason, my router and desktop computer are still able to contact each other by providing a lease of a local IP address. The router records a lease to my desktop computer, and when I do ipconfig, my desktop also recognizes that it has been provided a local IP address.

I have concluded that this is a hardware issue and the only solution to fix this is to buy a network card adapter, but I am wondering if anyone has any solutions that could explain why this happen, why my mac address is 01-23-45-67-89-ab, and is there any way to fix it without buying a new network card?

share|improve this question

1 Answer 1

Before buying a new card, get a laptop or something to test if it does connect. Have you done a hard reset on the router or reflashed the firmware.

Also it could also be the router acting up, if it's in warranty then call up the manufacturer for a replacement.

share|improve this answer
    
I did try to use a laptop and it did connect with each test. It shouldn't be the router since I connected the laptop straight to the modem and it worked, while I did the same thing to the desktop and it didn't work. –  AfterschoolHobbist Dec 31 '10 at 21:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.