Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm archiving my DVD collection. My goal is to be able to play them back in Windows Media Center on Windows 7 Ultimate. For feature-length DVDs, I'm using AnyDVD and CloneDVD, which is working well.

For playing back TV shows (and other episodic content), I'm using Media Browser, which doesn't support a VIDEO_TS folder per episode. It expects the shows to be broken up into one file per episode (e.g. "Willo the Wisp - S01E12.avi").

For this, I'm attempting to use Handbrake, which, for extracting the episodes from DVD (or already-ripped VIDEO_TS folder), is working pretty well.

The problem that I have is that the default x264 encoder over-compresses the resulting video stream, which results in hideous artifacts in animated shows. The aforementioned Willo the Wisp is a particularly bad example, because the original DVD is particularly "noisy".

If I switch to using the ffmpeg encoder, the artifacts are gone in Windows Media Player, but I can't get the resulting files to play back in Windows Media Center. I see the first frame, and then there's an error message: "Windows Media Center cannot play the file. One or more codecs required to play the file cannot be found."

I've installed the CCCP codec collection, but it doesn't seem to have made any difference.

Update: Using Handbrake's "High Profile" preset with either x264 or ffmpeg fails to play in Windows Media Center. In Windows Media Player, they both play, but the x264-encoded file has horrendous artifacts. If I use the "Normal" preset, it plays in Windows Media Center, but with the same artifacts.

So: what's the best way to convert VIDEO_TS to individual episode files for playback in Windows Media Center?

share|improve this question
    
have you tried playing with the video filters? the available filters are detelecine, decomb, deinterlace, denoise these might help greatly –  Patrick Jan 1 '11 at 17:23

3 Answers 3

Using Handbrake svn3722 with Windows Media Center:

  • "High Profile" doesn't play.
  • "High Profile" with filtering turned off (http://forum.handbrake.fr/viewtopic.php?f=7&t=19049&p=87836&hilit=windows+media+center#p87836) doesn't play
  • "High Profile" using ffmpeg doesn't play.

I thought I'd play with the audio codecs next:

  • "High Profile" with no faac (AC3 passthrough only) doesn't play.
  • "High Profile" with AC3 passthrough disabled plays, but with really bad artifacts

Then I tried the "Normal" settings:

  • "Normal" appears to play OK.
  • "Normal" using ffmpeg appears to play OK.

Looks like the SVN build improved the "Normal" preset to the point where the artifacts are gone. I'm going to finish ripping Willo the Wisp, and then I'll try something else.

share|improve this answer
1  
I'd certainly recommend taking this to the Handbrake forum, where the developers (and experienced users) may be able to help you identify what's going on. –  Cry Havok Jan 1 '11 at 15:27

Tackling these two issues separately:

  1. Many file formats won't play in Windows Media Center

    For whatever reason, Windows 7 uses an alternate framework to DirectShow called Media Foundation. What this means is that even if you install DirectShow codecs (like the CCCP you mentioned) for some formats, Windows Media Center won't necessarily use them.

    To make things work you're going to want to install Win7DSFilterTweaker. This will let you disable Media Foundation for certain file extensions. Disable it for any extensions you have trouble playing in WMC.

  2. What's the best format to use for ripping TV shows in WMC?

    I like to rip shows to .mkv files without re-encoding. This gives you the advantage of having a sigle file for each episode while still keeping them as the same quality they are on the DVD. It also allows you to keep any subtitle or alternate audio tracks along with them. I use MakeMKV for doing this. If you've installed the Haali Media Splitter (or any codec pack that includes it, like CCCP), you should be able to play .mkv files in WMC.

Good luck, hope this helps!

share|improve this answer
1  
what do you use to rip without re-encoding? –  rogerdpack Jun 3 '11 at 2:21

Have you tried the MP4 output in Handbrake instead (ideally using a recent nightly snapshot)? I've found in particular that the recent pre 0.95 snapshots produce artefact free conversions, no matter the source type (animation, CG or live) if you don't chose to over-compress. Indeed, I'd go as far to say that to get horrendous artefacts you have to be doing something very badly wrong or using a source that already has those artefacts.

I can't do justice to the settings here, the Handbrake Wiki and forums dedicate pages and pages of information on how the settings work and how to get the best from Handbrake.

share|improve this answer
    
Problem is: I don't want "pages and pages of information" :-( -- I'm using 0.9.4, so I'll try an SVN build and see how I get on. Also, what do you mean about "MP4 output". The MP4/MKV decision affects the container, not the codecs used. The "MPEG-4" encoder is the one I referred to as "ffmpeg", above. –  Roger Lipscombe Jan 1 '11 at 13:03
    
@Roger, the container may be part of the reason it "doesn't play". –  Cry Havok Jan 1 '11 at 14:28
    
Fair enough. I assumed that MP4/M4V would be more compatible than MKV. Seems to work with M4V under "Normal" (see my update). –  Roger Lipscombe Jan 1 '11 at 14:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.