Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use zsh on Mac OS X, with a theme based on "oh-my-zsh".

Each time I run a command, zsh "clears" the screen (really, inserting a few dozens newlines). This is very irritating, but I can't figure out how to turn this off.

What am I missing?

share|improve this question
    
Ok, this is a bit weird. I decided to play with the zsh commands in ~/.oh-my-zsh. I arbitrarily commented out "alias history='fc -l 1'" from one of the included files, and suddenly the screen clearing stopped. This is positively weird, and I can't figure out why it'd have that effect. Enlightenment welcome. –  optilude Jan 1 '11 at 16:47
    
Which oh-my-zsh theme are you using? –  mkomitee Jan 16 '11 at 15:55
add comment

migrated from serverfault.com Jan 1 '11 at 18:49

This question came from our site for professional system and network administrators.

2 Answers

As mentioned in the comments, commenting out the following from ~/.oh-my-zsh/lib/alias.zsh will fix the problem:

alias history='fc -l 1'
share|improve this answer
add comment

I have had similar troubles and found a solution by setting the TERM variable in my .zshrc file as so:

if [ `find /usr/share/terminfo -name "xterm-256color" -print` &> /dev/null ]; then
    export TERM='xterm-256color'
else
    export TERM='xterm'
fi

(No comment about using xterm over rxvt)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.