Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had some malware in my computer so I did a bit of manual work to remove it including resetting TCP/IP.

Now the malware is gone. I can see my home wireless network and I can get connected to it, but when connected I get the Internet wireless connected with limited access message.

When I go to the IE I cannot browse. When I tried to ping 192.168.1.1 I got an Error Code 1231 Unconnected Network Problem.

I have deactivated my Windows firewall as I thought it could be hyperactive security. Still no luck. I have Norton, but it is not active. I have also Avast and AVG installed, but they are not active.

Any ideas?

share|improve this question
3  
As a general note, 0 antivirus = bad, 1 antivirus = good, 2+ antiviruses = really bad. –  digitxp Jan 2 '11 at 16:09
    
thanks digitxp I will be removing the extra Avs, hope it will help in fixing my issue –  r0ca Jan 2 '11 at 16:32
    
Could you start a command prompt, run ipconfig /all and post the output? –  Jannemans Dec 30 '11 at 12:59

3 Answers 3

If you have multiple adapters configured (usually the case with most laptops that have wireless and wired), go to your network connections and disable the Internet connection you are not using (the wired connection will be called Local Area Network and the wired Wireless Connection).

Also, disable two antiviruses and stick with one. You will cause multiple problems if you let all three continue running.

share|improve this answer
1  
You don't need to disable adapters you aren't currently using. Also, you can set the preference of order for network adapters when multiple are connected: windowsreference.com/windows-vista/… –  MaQleod Nov 25 '11 at 20:59
    
@MaQleod - Yeah, I'm aware of that. However, I think taking an extra step to make absolutely sure that Windows is not using extra adapters (despite the order that is dictated through that dialog box) is a good idea regardless. –  White Phoenix Nov 26 '11 at 22:39

Generally I got Limited Acces error when I enter wrong password in wlan connections.

Do you connect wless?

I would first reset router/modem to which I connect to reset my password and try connecting again...

share|improve this answer

In Internet Options, go to the Advanced tab And do a Reset of IE. Reset everything.

Clean out your User Temp folder and the Temporary Internet Files folder

You have 3 Av products installed?

Did you flush your local DNS cache? ipconfig /flushdns

You may still be infected

Follow the order given below to properly disinfect your PC

1.) Make a boot AV disc then boot from the disc and scan the hard drive, remove any infections it finds, I prefer the Kaspersky disc myself. The New 2010 Kaspersky disc can update the AV dat files if you are connected to the internet at the time of scan and is suggested to update before the scan.

http://www.techmixer.com/free-bootable-antivirus-rescue-cds-download-list/

2.) Then: Install free MBAM, run the program and go to the Update tab and update it, then go to the Scanner Tab and do a quick scan, select and remove anything it finds.

http://download.cnet.com/Malwarebytes-Anti-Malware/3000-8022_4-10804572.html

3.) When MBAM is done install SAS free version, run a quick scan, remove what it automatically selects. http://www.superantispyware.com/download.html

These last 2 are not AV softwares like Norton, they are on demand scanners that only scan for nasties when you run the program and will not interfere with your installed AV, these can be run once a day or week to ensure you are not infected. Be sure you update them before each daily-weekly scan.

share|improve this answer
    
Hello Moab I will try your suggestions of resetting IE and flushing the DNS cash, I want you to know that other computers at home are working fine so the problem is within my laptop, it has windows vista. Sometimes it says check your security setting for connecting to wireless network. I also don’t see my wireless connection when I go to network sharing center. I hope this information can help you in giving some recipe. when i coonect it tells me I am connected with limited access, I have been installing these AVG, Avast, Then norton as I had some malware,now I will remove them I guess Thanks –  r0ca Jan 2 '11 at 16:17
    
You cannot have more then 1 AV installed at a time, this could be the problem. Follow my suggestions above to properly clean the PC of infections. Some malware is really malicious and can cause enough damage that you may consider a clean install. –  Moab Jan 2 '11 at 16:23
    
I forget to tell you about one thing i had removed winsock and winsock2 from registry then I reinstalled TCP/IP on network connection when I was trying to fix that malware before, I will remove all those AVs , you think that my laptop is useless now, is there chance to fix it thanks –  r0ca Jan 2 '11 at 16:30
    
is there any hotfix for my situation ? thanks –  r0ca Jan 2 '11 at 16:49
    
Are you going to follow my directions above? –  Moab Jan 2 '11 at 18:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.