Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running a freshly installed Windows 7 Professional (not RC or beta, and not illegal stuff). I installed my usual software, and I was surprised to see that VLC video playback is pixelated when resizing the video. I tried the video output, and one of them seemed to work OK (maybe direct X output), but that disabled aero, which is ugly. I have an nvidia Geforce 8500GT with 512MB RAM on it. Can you guys help me out? Vlc is a must :)


I tried all of the video output modes, and none of them worked. Reinstalling neither. Any ideas?

share|improve this question
add comment

5 Answers 5

up vote 3 down vote accepted

I have found a forum topic on VideoLAN forums. This is a well-known bug, and the devs say it is a bug in the drivers, not in VLC. Smelling some arrogance there, I might switch to GOM Player.

share|improve this answer
    
Sounds like a bitter comment. Trying another application is part of the troubleshooting process. Let us know how it works out –  Ciaran Aug 15 '09 at 21:08
    
GOM works well. I hope vlc gets cured soon though. –  Tamás Szelei Aug 16 '09 at 0:59
add comment

I switched from VLC to the MPC bundle ( CCCP ) much better in my opinion I'll never use VLC again

share|improve this answer
add comment

Using OpenGL Video Output from Preferences->Video solved the problem for me. All other options were giving me pixelated output. It doesn't disable Aero (I'm using Radeon HD4670 with 9.6 Catalyst drivers)

share|improve this answer
add comment

I've had a similar problem with VLC, except I was using Windows XP. My solution was to reinstall VLC - I think there was a config file that got buggered. Maybe this will work for you as well.

share|improve this answer
add comment

The problem isn’t VLC, or even the drivers; it’s Windows, or to be more specific, Aero.

In Windows XP, the hardware-accelerated overlay surface of the video-card was not used by Windows, and thus was free for programs to use to write data directly to the video card’s output. (Have you ever tried to get a screencap of a video and gotten a black rectangle when you pasted it? That was because you captured the overlay surface, not the actual video.)

In Windows 7, the Aero interface occupies the overlay surface to do its extensive fancy looking graphics and transparencies without slowing the system to a crawl. As a result, other programs cannot use the overlay (most video-cards only have one), and so videos have to resort to using software-rendering (eg using the CPU instead of GPU) to display the video instead. (Presumably, switching the screen into a full-screen mode, an app can use the overlay, though Alt-Tabbing to the desktop would then cause problems or at the least a delay as the video-card’s drivers are switch. Of course this is just theory, I have no actual evidence of programs using hardware-acceleration while Aero is running.)

As you discovered, the software-rendered display looks fairly different from the accelerated display. You also figured out that you can use the Direct-X output module to use acceleration, but that requires disabling Aero. Imran mentioned using OpenGL, but that is also a software-rendered module.

So here’s the scenario when viewing videos in Windows 7. You have a two basic choices:

  1. Disable Aero and use either a Windows Basic or Windows classic theme, but gain hardware-accelerated video.
  2. Keep Aero and use OpenGL (or other) output modules in your video player to render them in software. If you pick the default one, it will not look as good, but if you pick one that looks better (eg blending, smoothing, etc.) it will use more CPU.
share|improve this answer
    
Apparently they fixed it since then. What I don't understand is that if this was the cause of the problem, then how come other players worked well? –  Tamás Szelei Aug 1 '11 at 11:23
    
Other players default to a different renderers such as OpenGL, WMVR, etc. VLC may have “fixed” it by defaulting to a different renderer as well, but there is nothing they can do to “steal” the overlay surface from Aero because the video-card has only one. It may seem fixed, but it is still rendering in software and thus causing a higher CPU load than by using the hardware-accelerated overlay. –  Synetech Aug 2 '11 at 1:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.