Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I run Ubuntu 8.10 and many DVDs won't play for me and I don't know why. Is there more software that I need to install outside the default install? Neither Totem or Mplayer will play the DVDs.

share|improve this question
add comment

4 Answers

up vote 13 down vote accepted

This is well documented on the Ubuntu wiki.

Ubuntu 8.10 (i386, amd64)

Install the libdvdread3 package (no need to add third party repositories) via Synaptic or command line:

sudo apt-get install libdvdread3 gstreamer0.10-plugins-ugly

Then open a terminal window and execute:

sudo /usr/share/doc/libdvdread3/install-css.sh

See the wiki pages for other Ubuntu versions.

share|improve this answer
1  
Just for the record, if you're using Jaunty then you want libdvdread4 rather than libdvdread3. –  humble coffee Aug 15 '09 at 5:03
    
Dan said he's using 8.10, and the second link mentions libdvdread4 for Ubuntu 9.04, jaunty. –  jtimberman Aug 18 '09 at 14:07
add comment

DVD are usually encrypted and therefore, due to legal reasons, Ubuntu Linux does not ship the package which decrypt DVD

In order to be able to play encrypted DVDs, we need to install *libdvdcss2 /libdvdread4 * package

share|improve this answer
add comment

You could just install vlc - that normally works fine for me.

Alternatively you can use the medibuntu packages, though it is possible they may not be legal in the country you live in. Here are full instructions for using medibuntu. For playing DVDs, the key package is libdvdcss2.

share|improve this answer
add comment

If you have a newer system, have already installed libdvdcss2 and are still getting Add. Sense: Read of scrambled sector without authentication in dmesg, you may need to configure the region for your DVD drive.

For example, my Thinkpad W540 came with no region configured, so after installing libdvdcss2 it could play some DVDs (like Due South) but not others, like newer movies. It took me a while to figure out it was only having trouble with region-coded DVDs.

Anyway, to fix the problem:

# apt-get install regionset

After installing it, run it to configure the region for which you want to be able to read region-coded DVDs. You will probably need a DVD or CD in the drive, the run

# regionset

It will show you the current region (if any) and prompt you about changing it.

I kind of wonder about the mask. The default value worked for me, but I wonder if you can choose 0 to have it accept all regions. Does anyone know if that works?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.