Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My buddy is running Oracle VirtualBox, and everything works fine - except for the fact that the backslash ( \ ) key on a Swiss-German keyboard doesn't work - instead you're getting a vertical bar ( | ) - which is really quite annoying if you're trying to type in UNC paths....

The \ on a Swiss-German keyboard is on the key with the < and > signs - you need to press Alt Gr or Alt+Ctrl to get it. Is there any way to teach VirtualBox that we're using a Swiss German keyboard and that it should respect the keyboard layout??

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You don't need to tell VirtualBox anything. You need to configure the guest OS to recognize the Swiss German keyboard instead. Since you didn't mention what guest OS you're running, I can't help you to figure out how to do that, I'm afraid.

If your guest OS is Windows, you configure the keyboard and language using the Control Panel's Regional and Language Options, Languages tab.

share|improve this answer
    
Guest OS is Win7 - and it is configured for Swiss-German keyboard - but inside VirtualBox, some keys are strangely remapped and don't work properly - the backslash just being the most annoying of those... –  marc_s Jan 3 '11 at 19:29
    
Did you install the Guest Additions on VirtualBox? I don't have any strange keymappings on either Ubuntu or Win7 inside VirtualBox (but I'm not using a Swiss German keyboard, either). –  Ken White Jan 3 '11 at 19:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.