Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a brand new Lenovo T510 with Core i5 and 4GB of RAM with Windows 7 on it. I Installed Ubuntu 10.10 in a Virtualbox. For some reason system gets really slow on this setup which makes me really angry.

There's a video card shared with full 3D support enabled and 1GB of RAM allocated for the Ubuntu machine. It may sound stupid, but WHY is the whole memory consumed in an instant when I run Virtualbox?

I struggled for like 10 minutes restraining myself from a brutal reset, and now everything runs smooth but memory "in use" in Resource Monitor is 3GB flat with only Chrome running.

I'm new to Windows 7, but I'm really disappointed with performance at this point...

I used to work in a different environment with much slower hardware and there was no such problem (WinXP over Ubuntu, 1GB out of 2GB allocated for WinXP guest on intel GMA). This is, until I clogged RAM totally there. But I was capable of running Chrome, Firefox and Apache server on a 1GB RAM in Ubuntu there and Photoshop CS4 on Windows XP and it worked.

In this case I can't go beyond setting up Ubuntu properly. I bet I'm doing something wrong.

share|improve this question
    
Important: this machine is running Window 7 64bit. The Ubuntu is 32. –  Cyrylski Jan 3 '11 at 20:49

2 Answers 2

install the "Guest Additions" an everything it going to run smoothly, and with full mouse and clipboard integration, and better resolutions capabilities. I'm using actually the same combination win7 x64 with Ubuntu 10.10 and i have 70% memory used and depending on the applications that i launch between 20-50% cpu usage, mostly with programing stuff.

share|improve this answer
up vote 0 down vote accepted

After all it turned out to be caused by Norton Internet Security. I removed this bundled suite and everything runs fine. There were most likely some memory scans running, but I didn't care. Just removed it. Now it's fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.