Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have noticed a strange feature on my Dell Latitude running Windows 7 and Skype. When I am listening to music on the headphones, and Skype rings, then the audio I was listening to is redirected to the computer speakers, while Skype takes over the headphones. This is infuriating as my co-workers are treated to 1 second snippets of whatever rubbish I have on at the time.

Any ideas on how to stop this happening? I messed with some of the settings on Skype, but nothing seems to make any difference.

share|improve this question
A similar thing happens on some HP models too... – Corey Jan 4 '11 at 16:54
This is possibly the most obnoxious "feature" skype has. I have no idea why it's enabled by default. Good question! – nhinkle Feb 6 '11 at 11:16

3 Answers 3

up vote 4 down vote accepted

Only suggestion i could have is to check your media player, and Skype, and change them from using

  • Default Windows Playback Device

to specifically use one of

  • Realtek Audio Output
  • Logitech MRU-1601 Headphones

i.e. force it to something.

share|improve this answer
That was pretty close - I had to set the "Ringing" option to "Use Selected Speaker" (on Skype that is) – Greg Reynolds Jan 4 '11 at 17:02
I did this last time it happened. Just happened again, despite Ringing is set to "use selected Speaker". Skype is Hijacking all my audio devices, Like I have it set to ring on all devices, which I don't.. My Music Audio just played to my dev team. :S Even muted, it was skipping on and off. – Doomsknight Jan 27 '12 at 16:48

I've selected speakers instead of headphones from the Skype audio settings, and now Skype uses the same audio device as the player does

share|improve this answer

I have this exact problem too. I have bluetooth headphones for calls and music in the office. Everytime they disconnect Skype resets all it's audio settings. I reconnect and half the time skype comes out of my speakers rather than my headset.

The current workaround I use is to fully disable any output on my laptop other than the bluetooth headphones in the playback section of the audio settings (right click on the volume icon on the taskbar --> playback devices).

A little drastic but there are precious few instances where I want my work laptop to be making any noise. I wish I could just prohibit skype from using certain devices but you can only reorder the priority even then it only works if the devices are connected 100% of the time.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.